aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2011-08-16 08:13:10 +0000
committerSergey Poznyakoff <gray@gnu.org.ua>2011-08-16 08:13:10 +0000
commit56ac2b6a5d6eb829a7da8eecc04cbf5f9339e61b (patch)
tree5dc8009ac82abcfa8f22aa1ef38c85244af77a25 /configure.ac
parentae9ea0011da4ba01e5639611d61c442af8d42817 (diff)
downloadgdbm-56ac2b6a5d6eb829a7da8eecc04cbf5f9339e61b.tar.gz
gdbm-56ac2b6a5d6eb829a7da8eecc04cbf5f9339e61b.tar.bz2
Internationalization.
* Makefile.am (SUBDIRS): Add po. (EXTRA_DIST): Add build-aux/config.rpath. * configure.ac (AC_CONFIG_FILES): Add po/Makefile.in. * bootstrap: New file. * src/Makefile.am (AM_CPPFLAGS): Define LOCALEDIR (noinst_HEADERS): Add gettext.h (LIBADD): New variable. * src/gettext.h: New file. * po/.cvsignore: New file. * po/Makevars: New file. * po/POTFILES.in: New file. * src/gdbmdefs.h: Define DEFAULT_TEXT_DOMAIN, _, N_ Include gettext.h * src/bucket.c: Add NLS markers. * src/falloc.c: Likewise. * src/findkey.c: Likewise. * src/gdbmerrno.c: Likewise. * src/gdbmfetch.c: Likewise. * src/gdbmseq.c: Likewise. * src/gdbmstore.c: Likewise. * src/update.c: Likewise. * src/testgdbm.c: Add NLS markers. (main): Initialize I18N.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 9 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index fe009d5..23da438 100644
--- a/configure.ac
+++ b/configure.ac
@@ -76,7 +76,8 @@ AC_ARG_WITH([gdbm183-includedir],
[Build gdbmexport with gdbm.h in the specified directory.]),
[GDBM183_INCLUDEDIR=$withval],
[GDBM183_INCLUDEDIR="/usr/local/include"])
-
+
+dnl Check for programs
AC_PROG_CC
AC_PROG_CPP
AC_PROG_INSTALL
@@ -86,11 +87,15 @@ dnl AC_PROG_RANLIB
dnl AC_C_BIGENDIAN([])
AC_C_CONST
-AC_CHECK_HEADERS([stdlib.h string.h sys/file.h unistd.h fcntl.h sys/types.h memory.h sys/termios.h])
+dnl Internationalization macros.
+AM_GNU_GETTEXT([external], [need-ngettext])
+AM_GNU_GETTEXT_VERSION(0.18)
+
+AC_CHECK_HEADERS([stdlib.h string.h sys/file.h unistd.h fcntl.h sys/types.h memory.h sys/termios.h locale.h])
AC_CHECK_LIB(dbm, main)
AC_CHECK_LIB(ndbm, main)
-AC_CHECK_FUNCS([rename ftruncate flock lockf fsync])
+AC_CHECK_FUNCS([rename ftruncate flock lockf fsync setlocale])
if test x$mapped_io = xyes
then
@@ -109,7 +114,7 @@ AM_CONDITIONAL([ENABLE_EXPORT], [test "$want_export" = yes])
# Initialize the test suite.
AC_CONFIG_TESTDIR(tests)
-AC_CONFIG_FILES([tests/Makefile tests/atlocal])
+AC_CONFIG_FILES([tests/Makefile tests/atlocal po/Makefile.in])
AM_MISSING_PROG([AUTOM4TE], [autom4te])
AC_CONFIG_FILES([Makefile

Return to:

Send suggestions and report system problems to the System administrator.