aboutsummaryrefslogtreecommitdiff
path: root/compat/Makefile.am
diff options
context:
space:
mode:
authorJason Downs <downsj@downsj.com>2008-11-21 21:33:39 +0000
committerJason Downs <downsj@downsj.com>2008-11-21 21:33:39 +0000
commit10fe387708ddfba6449b9abd74cfbdf67d495465 (patch)
tree50115c0708c762940f580d081c73495bf148101a /compat/Makefile.am
downloadgdbm-10fe387708ddfba6449b9abd74cfbdf67d495465.tar.gz
gdbm-10fe387708ddfba6449b9abd74cfbdf67d495465.tar.bz2
Initial revision
Diffstat (limited to 'compat/Makefile.am')
-rw-r--r--compat/Makefile.am49
1 files changed, 49 insertions, 0 deletions
diff --git a/compat/Makefile.am b/compat/Makefile.am
new file mode 100644
index 0000000..ae3b972
--- /dev/null
+++ b/compat/Makefile.am
@@ -0,0 +1,49 @@
+# This file is part of GDBM. -*- Makefile -*-
+# Copyright (C) 2007 Free Software Foundation, Inc.
+#
+# GDBM is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GDBM is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GDBM. If not, see <http://www.gnu.org/licenses/>. */
+
+# Flags
+AM_CPPFLAGS=-I$(srcdir)/../src
+
+# The libraries
+VI_CURRENT = 4
+VI_REVISION = 0
+VI_AGE = 0
+
+lib_LTLIBRARIES = libgdbm_compat.la
+
+DBM_CF=\
+ dbminit.c\
+ delete.c\
+ fetch.c\
+ store.c\
+ seq.c\
+ close.c
+
+NDBM_CF=\
+ dbmopen.c\
+ dbmdelete.c\
+ dbmfetch.c\
+ dbmstore.c\
+ dbmseq.c\
+ dbmclose.c\
+ dbmdirfno.c\
+ dbmpagfno.c\
+ dbmrdonly.c
+
+libgdbm_compat_la_SOURCES = $(DBM_CF) $(NDBM_CF)
+
+libgdbm_compat_la_LDFLAGS = -version-info $(VI_CURRENT):$(VI_REVISION):$(VI_AGE)
+

Return to:

Send suggestions and report system problems to the System administrator.