aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2011-08-03 13:30:50 +0000
committerSergey Poznyakoff <gray@gnu.org.ua>2011-08-03 13:30:50 +0000
commit543b3a9c67691e2ef23a8b68e901c6ec49b5bfb8 (patch)
tree3c0415669e223dd120dff547dc72f40e57f0b24d /Makefile.am
parent50f332ec721165bf092f299bfd5379a7e05f0354 (diff)
downloadgdbm-543b3a9c67691e2ef23a8b68e901c6ec49b5bfb8.tar.gz
gdbm-543b3a9c67691e2ef23a8b68e901c6ec49b5bfb8.tar.bz2
Makefile.am (dist-hook): Replace /*@DIST_DATE@*/ with the actual distribution date.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0a9f2c3..e503087 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,3 +23,8 @@ if ENABLE_EXPORT
MAYBE_EXPORT = export
endif
SUBDIRS = src doc $(MAYBE_COMPAT) $(MAYBE_EXPORT) tests
+
+dist-hook:
+ d=`date '+%d/%m/%Y'`; \
+ sed 's|/\*@DIST_DATE@\*/|"'"$$d"'"|' $(srcdir)/src/version.c > \
+ $(distdir)/src/version.c

Return to:

Send suggestions and report system problems to the System administrator.