aboutsummaryrefslogtreecommitdiff
path: root/xml/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xml/Makefile.am')
-rw-r--r--xml/Makefile.am24
1 files changed, 13 insertions, 11 deletions
diff --git a/xml/Makefile.am b/xml/Makefile.am
index 3ec5c4d..151d03d 100644
--- a/xml/Makefile.am
+++ b/xml/Makefile.am
@@ -1,5 +1,5 @@
# This file is part of Ellinika project.
-# Copyright (C) 2004, 2006, 2007 Sergey Poznyakoff
+# Copyright (C) 2004, 2006, 2007, 2015 Sergey Poznyakoff
#
# Ellinika is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -21,16 +21,18 @@ CLEANFILES=conf.sed
noinst_DATA= lingua.conf
conf.sed: Makefile
- echo 's,=TMPDIR=,$(top_builddir)/../tmp,g' > conf.sed
- echo 's,=OUTDIR=,$(top_builddir)/../html,g' >> conf.sed
- echo 's,=TARGET_DIR=,$(TARGET_DIR),g' >> conf.sed
- echo 's,=SCRIPT_SUFFIX=,$(SCRIPT_SUFFIX),g' >> conf.sed
- echo 's,=SCRIPT_DIR=,$(SCRIPT_DIR),g' >> conf.sed
- echo 's,=BASE_HREF=,$(BASE_HREF),g' >> conf.sed
- echo 's,=PACKAGE_BUGREPORT=,$(PACKAGE_BUGREPORT),g' >> conf.sed
- echo 's,=PROD_URL=,$(PROD_URL),g' >> conf.sed
- echo 's,=EXP_URL=,$(EXP_URL),g' >> conf.sed
+ $(AM_V_GEN){ \
+ echo 's,=TMPDIR=,$(top_builddir)/../tmp,g'; \
+ echo 's,=OUTDIR=,$(top_builddir)/../html,g'; \
+ echo 's,=TARGET_DIR=,$(TARGET_DIR),g'; \
+ echo 's,=SCRIPT_SUFFIX=,$(SCRIPT_SUFFIX),g'; \
+ echo 's,=SCRIPT_DIR=,$(SCRIPT_DIR),g'; \
+ echo 's,=BASE_HREF=,$(BASE_HREF),g'; \
+ echo 's,=PACKAGE_BUGREPORT=,$(PACKAGE_BUGREPORT),g'; \
+ echo 's,=PROD_URL=,$(PROD_URL),g'; \
+ echo 's,=EXP_URL=,$(EXP_URL),g'; \
+ } > conf.sed
lingua.conf: $(srcdir)/lingua.conf.in conf.sed
- sed -f conf.sed $(srcdir)/lingua.conf.in > $@
+ $(AM_V_GEN)sed -f conf.sed $(srcdir)/lingua.conf.in > $@

Return to:

Send suggestions and report system problems to the System administrator.