aboutsummaryrefslogtreecommitdiff
path: root/src/ellinika/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/ellinika/Makefile.am')
-rw-r--r--src/ellinika/Makefile.am62
1 files changed, 31 insertions, 31 deletions
diff --git a/src/ellinika/Makefile.am b/src/ellinika/Makefile.am
index 12e0392..5f476ef 100644
--- a/src/ellinika/Makefile.am
+++ b/src/ellinika/Makefile.am
@@ -1,5 +1,5 @@
# This file is part of Ellinika project.
-# Copyright (C) 2004,2006,2007,2008,2011 Sergey Poznyakoff
+# Copyright (C) 2004, 2006-2008, 2011, 2015 Sergey Poznyakoff
#
# Ellinika is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -14,8 +14,8 @@
# You should have received a copy of the GNU General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
-guiledir=$(GUILE_SITE)/$(PACKAGE)
-guile_DATA=\
+sitedir=$(GUILE_SITE)/$(PACKAGE)
+site_DATA=\
xlat.scm\
cgi.scm\
i18n.scm\
@@ -27,29 +27,31 @@ guile_DATA=\
conjugator.scm
cgi.m4: Makefile
- echo 'divert(-1)' > $@
- echo 'changequote([,])' >> $@
- echo 'changecom([;],[' >> $@
- echo '])' >> $@
- echo 'undefine([format])' >> $@
- echo 'define([IFACE],[$(APACHE_IFACE)])' >> $@
- echo 'define([SCRIPT_SUFFIX], [@SCRIPT_SUFFIX@])'>>$@
- echo 'define([GUILE_BINDIR],[$(GUILE_BINDIR)])' >> $@
- echo 'define([GUILE_SITE],[@GUILE_SITE@])' >> $@
- echo 'define([PACKAGE],[$(PACKAGE)])'>> $@
- echo 'define([PREFIX],[$(prefix)])' >> $@
- echo 'define([SYSCONFDIR],[$(sysconfdir)])' >> $@
- echo 'define([LOCALEDIR],[$(datadir)/locale])' >> $@
- echo 'define([HTMLDIR],[$(HTMLDIR)])' >> $@
- echo 'define([VERSION],[$(VERSION)])' >> $@
- echo 'define([LIBDIR],[$(pkglibdir)])' >> $@
- echo 'divert(0)dnl' >> $@
- echo '@AUTOGENERATED@' >> $@
+ $(AM_V_GEN){ \
+ echo 'divert(-1)'; \
+ echo 'changequote([,])'; \
+ echo 'changecom([;],['; \
+ echo '])'; \
+ echo 'undefine([format])'; \
+ echo 'define([IFACE],[$(APACHE_IFACE)])'; \
+ echo 'define([SCRIPT_SUFFIX], [@SCRIPT_SUFFIX@])'; \
+ echo 'define([GUILE_BINDIR],[$(GUILE_BINDIR)])'; \
+ echo 'define([GUILE_SITE],[@GUILE_SITE@])'; \
+ echo 'define([PACKAGE],[$(PACKAGE)])'; \
+ echo 'define([PREFIX],[$(prefix)])'; \
+ echo 'define([SYSCONFDIR],[$(sysconfdir)])'; \
+ echo 'define([LOCALEDIR],[$(datadir)/locale])'; \
+ echo 'define([HTMLDIR],[$(HTMLDIR)])'; \
+ echo 'define([VERSION],[$(VERSION)])'; \
+ echo 'define([LIBDIR],[$(pkglibdir)])'; \
+ echo 'divert(0)dnl'; \
+ echo '@AUTOGENERATED@'; \
+ } > cgi.m4
SUFFIXES = .scm4 .scm .x
.scm4.scm:
- m4 -I$(srcdir) cgi.m4 $< > $@
+ $(AM_V_GEN)m4 -I$(srcdir) cgi.m4 $< > $@
cgi.scm: cgi.scm4 cgi.m4
config.scm: config.scm4 cgi.m4
@@ -68,17 +70,9 @@ libelmorph_la_SOURCES = \
syllabificator.c
DOT_X_FILES = elmorph.x utf8scm.x
-
BUILT_SOURCES = $(DOT_X_FILES)
-
DISTCLEANFILES = $(DOT_X_FILES)
-snarfcppopts = $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
-
-.c.x:
- AWK=$(AWK) \
- guile-snarf -o $@ $< $(snarfcppopts)
-
pkglibnames=elmorph
install-data-hook:
@@ -95,4 +89,10 @@ install-data-hook:
AM_YFLAGS = -d
YACCCOMPILE = $(srcdir)/yyrename '$(YACC) $(YFLAGS) $(AM_YFLAGS)'
-EXTRA_DIST = yyrename elmorph-public.scm \ No newline at end of file
+EXTRA_DIST = yyrename elmorph-public.scm
+
+AM_CPPFLAGS=-I.
+CLEANFILES=
+MAINTAINERCLEANFILES=
+include ../../gint/gint.mk
+

Return to:

Send suggestions and report system problems to the System administrator.