aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 5 insertions, 24 deletions
diff --git a/configure.ac b/configure.ac
index 147b586..b025426 100644
--- a/configure.ac
+++ b/configure.ac
@@ -15,15 +15,9 @@ AC_SUBST(M4)
AM_GNU_GETTEXT(external, need-ngettext)
AM_GNU_GETTEXT_VERSION(0.13)
-RA_CHECK_GUILE(,
- [case "$GUILE_VERSION" in
- 14) AC_MSG_ERROR([You need Guile 1.6 or better]);;
- 16|17) GUILE_SNARF_VERSION="1.6";;
- *) ;;
- esac],
+MU_CHECK_GUILE(,,
[AC_MSG_ERROR([You need Guile 1.6 or better])])
-
RA_CHECK_LIB(mysqlclient,
mysql_real_connect,
[-lm],
@@ -36,25 +30,12 @@ LIBS="$LIBS $ra_cv_lib_mysqlclient"
## **************
## Directories
## **************
-
AC_SUBST(GUILE_BINDIR)
GUILE_BINDIR=`guile-config info bindir`
-
-AC_SUBST(GUILE_SITE)
-GUILE_SITE=
-AC_ARG_WITH([guile-site],
- AC_HELP_STRING([--with-guile-site],
- [Install modules into the default guile site directory]),
- [case $withval in
- yes) GUILE_SITE=`guile-config info pkgdatadir`/site/'$(PACKAGE)';;
- esac])
-
-if test "$GUILE_SITE" = ""; then
- GUILE_SITE='$(pkgdatadir)'
- AC_SUBST(UPDPATH)
- UPDPATH="(set! %load-path (cons \\\"\$\$s\\\" %load-path))"
-fi
+# FIXME: This is not always needed
+AC_SUBST(UPDPATH)
+UPDPATH="(set! %load-path (cons \\\"\$\$s\\\" %load-path))"
CGIDIR='$(prefix)/cgi-bin'
AC_ARG_WITH(cgi-bin,
@@ -81,4 +62,4 @@ AC_CONFIG_FILES(Makefile
xml/Makefile
po/Makefile.in)
-AC_OUTPUT \ No newline at end of file
+AC_OUTPUT

Return to:

Send suggestions and report system problems to the System administrator.