aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac69
1 files changed, 69 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..fe0af96
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,69 @@
+AC_PREREQ(2.59)
+
+AC_REVISION($Revision$)
+AC_INIT(ellinika, 1.0, gray@gnu.org)
+AC_CONFIG_SRCDIR(cgi-bin/dict.cgi.in)
+AC_CONFIG_AUX_DIR([scripts])
+AC_CANONICAL_SYSTEM
+AM_INIT_AUTOMAKE(no-exeext)
+AC_CONFIG_HEADERS([config.h])
+
+## * Checks for programs.
+AC_PROG_CC
+AM_PROG_CC_STDC
+AC_PROG_YACC
+AM_PROG_LEX
+AC_PROG_AWK
+
+M4='`cd $(top_srcdir); pwd`/scripts/missing --run m4'
+AC_SUBST(M4)
+
+AM_GNU_GETTEXT(external, need-ngettext)
+AM_GNU_GETTEXT_VERSION(0.13)
+
+RA_CHECK_GUILE(,
+ [case "$GUILE_VERSION" in
+ 14) AC_MSG_ERROR([You need Guile 1.6 or better]);;
+ 16|17) GUILE_SNARF_VERSION="1.6";;
+ *) ;;
+ esac],
+ [AC_MSG_ERROR([You need Guile 1.6 or better])])
+
+RA_CHECK_LIB(mysqlclient,
+ mysql_real_connect,
+ [-lm],
+ [],
+ [AC_MSG_FAILURE([The required library libmysqlclient is not found or is unusable])],
+ [/usr/local/lib/mysql /usr/lib/mysql])
+
+LIBS="$LIBS $ra_cv_lib_mysqlclient"
+
+## **************
+## Directories
+## **************
+
+CGIDIR='$(prefix)/cgi-bin'
+AC_ARG_WITH(cgi-bin,
+ AC_HELP_STRING([--with-cgi-bin=DIR],
+ [install CGI programs in DIR [[PREFIX/cgi-bin]]]),
+ [CGIDIR=$withval])
+AC_SUBST(CGIDIR)
+
+HTMLDIR='$(prefix)/ellinika'
+AC_ARG_WITH(html-dir,
+ AC_HELP_STRING([--with-html-dir=DIR],
+ [install HTML pages in DIR [[PREFIX/ellinika]]]),
+ [HTMLDIR=$withval])
+AC_SUBST(HTMLDIR)
+
+AC_SUBST(BASE_HREF)
+AC_SUBST(TARGET_DIR)
+
+AC_OUTPUT(Makefile
+ cgi-bin/Makefile
+ data/Makefile
+ src/Makefile
+ xml/Makefile
+ xtrans/Makefile
+ html/Makefile
+ po/Makefile.in)

Return to:

Send suggestions and report system problems to the System administrator.