aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2c075fc..2e4dd7e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,5 @@
# This file is part of Ellinika project.
-# Copyright (C) 2004, 2007, 2008, 2010 Sergey Poznyakoff
+# Copyright (C) 2004, 2007, 2008, 2010, 2015 Sergey Poznyakoff
#
# Ellinika is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -48,3 +48,11 @@ install-html:
done
install-data-local: install-html
+
+.PHONY: ChangeLog
+ChangeLog:
+ $(AM_V_GEN)if test -d .git; then \
+ git log --pretty='format:%ct %an <%ae>%n%n%s%n%n%b%n' | \
+ awk -f $(top_srcdir)/git2chg.awk \
+ -v append=$(top_srcdir)/ChangeLog.svn > ChangeLog; \
+ fi

Return to:

Send suggestions and report system problems to the System administrator.