aboutsummaryrefslogtreecommitdiff
path: root/xml/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org>2015-01-06 21:44:01 +0200
committerSergey Poznyakoff <gray@gnu.org>2015-01-06 21:44:01 +0200
commit5dfd8dd432785ca8d8b6d2c11bac9e110feda52b (patch)
treebfe12bf71b50e7916ab5b957ba216def8c41cbf9 /xml/Makefile.am
parentc5e668cfd92985ff7e3e4be7c6be8c3ea3e6d57f (diff)
downloadellinika-5dfd8dd432785ca8d8b6d2c11bac9e110feda52b.tar.gz
ellinika-5dfd8dd432785ca8d8b6d2c11bac9e110feda52b.tar.bz2
Update for Guile 2.0
* .gitmodules: New file * gint: New module. * Makefile.am (ACLOCAL_AMFLAGS, SUBDIRS): Add gint * autogen.sh: Create a placeholder for ChangeLog. * configure.ac: Add gint. * scm/Makefile.am: Add silent rule magic. * src/cgi-bin/Makefile.am: Likewise. * src/ellinika/Makefile.am: Likewise. * xml/Makefile.am: Likewise. * scm/dictrans.scm: Load (ice-9 syncase) only for Guile 1.x * scm/neatrans.scm: Likewise. * src/ellinika/conjugator.scm: Likewise. * src/ellinika/elmorph.c (elstr)<phoneme_count,nsyl>: Change type to size_t. * xml/pl/Makefile.am: Force UTF-8 locale when building html. Add silent rule magic. * xml/ru/Makefile.am: Likewise. * xml/uk/Makefile.am: Likewise.
Diffstat (limited to 'xml/Makefile.am')
-rw-r--r--xml/Makefile.am24
1 files changed, 13 insertions, 11 deletions
diff --git a/xml/Makefile.am b/xml/Makefile.am
index 3ec5c4d..151d03d 100644
--- a/xml/Makefile.am
+++ b/xml/Makefile.am
@@ -1,5 +1,5 @@
# This file is part of Ellinika project.
-# Copyright (C) 2004, 2006, 2007 Sergey Poznyakoff
+# Copyright (C) 2004, 2006, 2007, 2015 Sergey Poznyakoff
#
# Ellinika is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -21,16 +21,18 @@ CLEANFILES=conf.sed
noinst_DATA= lingua.conf
conf.sed: Makefile
- echo 's,=TMPDIR=,$(top_builddir)/../tmp,g' > conf.sed
- echo 's,=OUTDIR=,$(top_builddir)/../html,g' >> conf.sed
- echo 's,=TARGET_DIR=,$(TARGET_DIR),g' >> conf.sed
- echo 's,=SCRIPT_SUFFIX=,$(SCRIPT_SUFFIX),g' >> conf.sed
- echo 's,=SCRIPT_DIR=,$(SCRIPT_DIR),g' >> conf.sed
- echo 's,=BASE_HREF=,$(BASE_HREF),g' >> conf.sed
- echo 's,=PACKAGE_BUGREPORT=,$(PACKAGE_BUGREPORT),g' >> conf.sed
- echo 's,=PROD_URL=,$(PROD_URL),g' >> conf.sed
- echo 's,=EXP_URL=,$(EXP_URL),g' >> conf.sed
+ $(AM_V_GEN){ \
+ echo 's,=TMPDIR=,$(top_builddir)/../tmp,g'; \
+ echo 's,=OUTDIR=,$(top_builddir)/../html,g'; \
+ echo 's,=TARGET_DIR=,$(TARGET_DIR),g'; \
+ echo 's,=SCRIPT_SUFFIX=,$(SCRIPT_SUFFIX),g'; \
+ echo 's,=SCRIPT_DIR=,$(SCRIPT_DIR),g'; \
+ echo 's,=BASE_HREF=,$(BASE_HREF),g'; \
+ echo 's,=PACKAGE_BUGREPORT=,$(PACKAGE_BUGREPORT),g'; \
+ echo 's,=PROD_URL=,$(PROD_URL),g'; \
+ echo 's,=EXP_URL=,$(EXP_URL),g'; \
+ } > conf.sed
lingua.conf: $(srcdir)/lingua.conf.in conf.sed
- sed -f conf.sed $(srcdir)/lingua.conf.in > $@
+ $(AM_V_GEN)sed -f conf.sed $(srcdir)/lingua.conf.in > $@

Return to:

Send suggestions and report system problems to the System administrator.