aboutsummaryrefslogtreecommitdiff
path: root/src/ellinika/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2011-06-10 23:04:53 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2011-06-11 00:34:20 +0300
commita1a5b7ddd6c3c0532c37551b24fd573a554ac181 (patch)
treef86f3572c77dc986bb2dfb65619ac4bc35c83847 /src/ellinika/Makefile.am
parent2bae7da012e2125762855ce014e63345ecbbbb18 (diff)
downloadellinika-a1a5b7ddd6c3c0532c37551b24fd573a554ac181.tar.gz
ellinika-a1a5b7ddd6c3c0532c37551b24fd573a554ac181.tar.bz2
Fix syllabification.
* configure.ac: Add AC_PROG_YACC * src/ellinika/phoneme.y: New file. * src/ellinika/yyrename: New file. * src/ellinika/syllabificator.c: New file. * src/ellinika/.gitignore: Update. * src/ellinika/elchr.c (char_info_st): Move to header. (el_basic_ctype): (elchr_info): Remove static qualifier. Return a pointer to const. (elchr_letter,elchr_phoneme): New functions. (elchr_diphthong): Remove. * src/ellinika/elmorph.c (elstr)<phoneme,phoneme_count>: New members. (_elstr_syllabize): Rewrite. (invalidate_maps)" New static function. (_elstr_alloc): Initialize new fields, take function name as argument, for diagnostic purposes. (_elstr_print): Rewrite (deftab): Update. (elstr-syllable-prop,elstr-syllable) (_elstr_set_accent,_elstr_set_accent_on_char): Rewrite. (elstr-char-phoneme,elstr->phonetic-map): New functions. * src/ellinika/elmorph.h (CHF_DIPH1,CHF_DIPH2): Remove. (CHF_DIPHTHONG): New flag. (PHON_.*): New constants. (phoneme,syllable): New structures. (char_info_st)<letter,phoneme>: New members. (elchr_info,elchr_letter) (elchr_phoneme,phoneme_map) (syllable_map): New protos. (elchr_diphthong): Remove protos. * src/ellinika/elmorph.scm4: Move public definitions to elmorph-public.scm; include it here. * src/ellinika/xlat.scm (ellinika:sounds-like): Rewrite as a wrapper over elstr->soundslike. Describe Milesian numbers. * style.css (img.ellinika-img): New class. * xml/lingua.conf.in (IMAGE): New tag. * xml/pl/alfabhta.xml: Describe Milesian numbers. Various fixes. * data/dbverb.struct: fix a typo in flection. Use 'sub' theme for pas/sub/aor. * data/irregular-verbs.xml: Add more verbs. * scm/conjugator.scm: Various fixes. * scm/verbop.scm: Accept empty mood and voice declarations.
Diffstat (limited to 'src/ellinika/Makefile.am')
-rw-r--r--src/ellinika/Makefile.am23
1 files changed, 17 insertions, 6 deletions
diff --git a/src/ellinika/Makefile.am b/src/ellinika/Makefile.am
index 274eea8..b8988d4 100644
--- a/src/ellinika/Makefile.am
+++ b/src/ellinika/Makefile.am
@@ -1,5 +1,5 @@
# This file is part of Ellinika project.
-# Copyright (C) 2004,2006,2007,2008 Sergey Poznyakoff
+# Copyright (C) 2004,2006,2007,2008,2011 Sergey Poznyakoff
#
# Ellinika is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -15,7 +15,14 @@
# along with this program. If not, see <http://www.gnu.org/licenses/>.
guiledir=$(GUILE_SITE)/$(PACKAGE)
-guile_DATA=xlat.scm cgi.scm i18n.scm config.scm dico.scm elmorph.scm
+guile_DATA=\
+ xlat.scm\
+ cgi.scm\
+ i18n.scm\
+ config.scm\
+ dico.scm\
+ elmorph.scm\
+ tenses.scm
cgi.m4: Makefile
echo 'divert(-1)' > $@
@@ -39,11 +46,11 @@ cgi.m4: Makefile
SUFFIXES = .scm4 .scm .x
.scm4.scm:
- m4 cgi.m4 $< > $@
+ m4 -I$(srcdir) cgi.m4 $< > $@
cgi.scm: cgi.scm4 cgi.m4
config.scm: config.scm4 cgi.m4
-elmorph.scm: elmorph.scm4 cgi.m4
+elmorph.scm: elmorph.scm4 elmorph-public.scm cgi.m4
pkglib_LTLIBRARIES=libelmorph.la
@@ -52,7 +59,9 @@ libelmorph_la_SOURCES = \
utf8.c\
elchr.c\
elmorph.c\
- elmorph.h
+ elmorph.h\
+ phoneme.y\
+ syllabificator.c
DOT_X_FILES = elmorph.x
@@ -80,4 +89,6 @@ install-data-hook:
done; \
cd $$here
-
+AM_YFLAGS = -d
+YACCCOMPILE = $(srcdir)/yyrename '$(YACC) $(YFLAGS) $(AM_YFLAGS)'
+EXTRA_DIST = yyrename elmorph-public.scm \ No newline at end of file

Return to:

Send suggestions and report system problems to the System administrator.