aboutsummaryrefslogtreecommitdiff
path: root/src/cgi-bin/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2008-06-22 07:33:31 +0000
committerSergey Poznyakoff <gray@gnu.org.ua>2008-06-22 07:33:31 +0000
commit4eb48d2f187bc9bb3266cee025da2ea61270e4c4 (patch)
treea99c057485f72d9074d22ea518804a4c8d2eb5bb /src/cgi-bin/Makefile.am
parent64af4748a2cae68c7ff4aa48d3dc7c93a2d469f6 (diff)
downloadellinika-4eb48d2f187bc9bb3266cee025da2ea61270e4c4.tar.gz
ellinika-4eb48d2f187bc9bb3266cee025da2ea61270e4c4.tar.bz2
Move cgi-bin and ellinika to src.
* src: New dir * src/Makefile.am: New file. * cgi-bin, ellinika: Move to src. * configure.ac: Reflect the above changes. git-svn-id: file:///home/puszcza/svnroot/ellinika/trunk@525 941c8c0f-9102-463b-b60b-cd22ce0e6858
Diffstat (limited to 'src/cgi-bin/Makefile.am')
-rw-r--r--src/cgi-bin/Makefile.am56
1 files changed, 56 insertions, 0 deletions
diff --git a/src/cgi-bin/Makefile.am b/src/cgi-bin/Makefile.am
new file mode 100644
index 0000000..bb90eed
--- /dev/null
+++ b/src/cgi-bin/Makefile.am
@@ -0,0 +1,56 @@
+# This file is part of Ellinika project.
+# Copyright (C) 2004, 2005, 2007, 2008 Sergey Poznyakoff
+#
+# Ellinika is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
+#
+# Ellinika is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+cgidir=@CGIDIR@
+cgi_SCRIPTS=$(EXTRA_DIST:.scm4=.@SCRIPT_SUFFIX@)
+EXTRA_DIST=dict.scm4 nea.scm4
+CLEANFILES=dict.m4 dict.scm nea.scm dict.cgi nea.cgi
+
+dict.m4: Makefile
+ echo 'divert(-1)' > $@
+ echo 'changequote([,])' >> $@
+ echo 'changecom([;],[' >> $@
+ echo '])' >> $@
+ echo 'undefine([format])' >> $@
+ echo 'define([IFACE],$(APACHE_IFACE))' >> $@
+ echo 'define([GUILE_BINDIR],$(GUILE_BINDIR))' >> $@
+ echo 'define([GUILE_SITE],@GUILE_SITE@)' >> $@
+ echo 'define([PACKAGE],$(PACKAGE))'>> $@
+ echo 'define([PREFIX],$(prefix))' >> $@
+ echo 'define([SYSCONFDIR],$(sysconfdir))' >> $@
+ echo 'define([LOCALEDIR],$(datadir)/locale)' >> $@
+ echo 'define([HTMLDIR],$(HTMLDIR))' >> $@
+ echo 'divert(0)dnl' >> $@
+ echo 'ifelse(IFACE,[CGI],#! $(GUILE_BINDIR)/guile -s' >> $@
+ echo ')dnl' >> $@
+ echo '@AUTOGENERATED@' >> $@
+ echo 'ifelse(IFACE,[CGI],!#' >> $@
+ echo ')dnl' >> $@
+
+SUFFIXES = .scm4 .scm .cgi
+
+.scm4.scm:
+ m4 dict.m4 $< > $@
+
+.scm.cgi:
+ cp $< $@
+
+dict.scm: dict.scm4 dict.m4
+nea.scm: nea.scm4 dict.m4
+
+dict.cgi: dict.scm
+nea.cgi: nea.scm
+

Return to:

Send suggestions and report system problems to the System administrator.