aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2006-10-08 21:40:32 +0000
committerSergey Poznyakoff <gray@gnu.org.ua>2006-10-08 21:40:32 +0000
commitc84f3061d0be6dd349fee9222002c69a84b5f66e (patch)
tree519fcb8ec1d1976f9400d088feb78ce6384a5b29 /configure.ac
parent109cf4d84378cbfce6b157ac854383be2a9ea866 (diff)
downloadellinika-c84f3061d0be6dd349fee9222002c69a84b5f66e.tar.gz
ellinika-c84f3061d0be6dd349fee9222002c69a84b5f66e.tar.bz2
Use build-aux as an aux dir.
New option --enable-cgi git-svn-id: file:///home/puszcza/svnroot/ellinika/trunk@461 941c8c0f-9102-463b-b60b-cd22ce0e6858
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac43
1 files changed, 32 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 01d5b4a..be489b4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,9 +19,9 @@
AC_PREREQ(2.59)
AC_REVISION($Revision$)
-AC_INIT(ellinika, 1.0, gray@gnu.org)
+AC_INIT(ellinika, 1.1, gray@gnu.org)
AC_CONFIG_SRCDIR(cgi-bin/dict.cgi.in)
-AC_CONFIG_AUX_DIR([scripts])
+AC_CONFIG_AUX_DIR([build-aux])
AC_CANONICAL_SYSTEM
AM_INIT_AUTOMAKE(no-exeext)
@@ -61,13 +61,6 @@ AC_SUBST(GUILE_COMMENT)
AC_SUBST(GUILE_SITE)
-CGIDIR='$(prefix)/cgi-bin'
-AC_ARG_WITH(cgi-bin,
- AC_HELP_STRING([--with-cgi-bin=DIR],
- [install CGI programs in DIR [[PREFIX/cgi-bin]]]),
- [CGIDIR=$withval])
-AC_SUBST(CGIDIR)
-
HTMLDIR='$(prefix)/ellinika'
AC_ARG_WITH(html-dir,
AC_HELP_STRING([--with-html-dir=DIR],
@@ -75,6 +68,34 @@ AC_ARG_WITH(html-dir,
[HTMLDIR=$withval])
AC_SUBST(HTMLDIR)
+AC_SUBST(APACHE_IFACE,CGI)
+AC_ARG_ENABLE(cgi,
+ AC_HELP_STRING([--enable-cgi],
+ [Use CGI or SCM]),
+ [case $enableval in
+ yes) APACHE_IFACE=CGI;;
+ no) APACHE_IFACE=SCM;;
+ *) AC_MSG_ERROR([unknown argument to --enable-cgi])
+ esac])
+
+AC_SUBST(SCRIPT_SUFFIX)
+AC_SUBST(SCRIPT_DIR)
+AC_SUBST(CGIDIR)
+if test $APACHE_IFACE = "CGI"; then
+ SCRIPT_SUFFIX=cgi
+ SCRIPT_DIR=/cgi-name
+ CGIDIR='$(prefix)/cgi-bin'
+else
+ SCRIPT_SUFFIX=scm
+ SCRIPT_DIR=
+ CGIDIR='$(HTMLDIR)'
+fi
+
+AC_ARG_WITH(cgi-bin,
+ AC_HELP_STRING([--with-cgi-bin=DIR],
+ [install CGI programs in DIR [[PREFIX/cgi-bin]]]),
+ [CGIDIR=$withval])
+
AC_SUBST(BASE_HREF)
AC_SUBST(TARGET_DIR)
@@ -85,8 +106,8 @@ if test "$EMACS" != "no"; then
fi
AC_SUBST(lisp_LISP)
-AC_SUBST(AUTOGENERATED)
-AUTOGENERATED=";;;; This file is generated automatically. Please do not edit."
+AC_SUBST(AUTOGENERATED,
+ ";;;; This file is generated automatically. Please do not edit. -*- buffer-read-only: t -*- vi: set ro:")
AC_CONFIG_FILES(Makefile
cgi-bin/Makefile

Return to:

Send suggestions and report system problems to the System administrator.