aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2006-03-22 21:27:17 +0000
committerSergey Poznyakoff <gray@gnu.org.ua>2006-03-22 21:27:17 +0000
commitfa005a94a8dd158de7e79b32b4b0cea3b621553b (patch)
treee3b04125172b84d7ae146d1fa1c8304b6ace062e /Makefile.am
parent24d3f7a6f42d7d927800b300b7f82de3e6e69d7d (diff)
downloadellinika-fa005a94a8dd158de7e79b32b4b0cea3b621553b.tar.gz
ellinika-fa005a94a8dd158de7e79b32b4b0cea3b621553b.tar.bz2
Add .htaccess
git-svn-id: file:///home/puszcza/svnroot/ellinika/trunk@382 941c8c0f-9102-463b-b60b-cd22ce0e6858
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am24
1 files changed, 17 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 30f2c2f..902109b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,20 +23,30 @@ SUBDIRS=cgi-bin elisp data ellinika scm xml po
htmldir = $(HTMLDIR)
html_DATA = mainstyle.css
+EXTRA_DIST=.htaccess
install-html:
+ ${INSTALL} -m 644 .htaccess $(DESTDIR)$(HTMLDIR)
+ top_srcdir=`cd $(top_srcdir);pwd`; \
for dir in el pl ru; do \
here=`pwd`; \
- cd $(top_srcdir)/html/$$dir; \
- if test -d $(DESTDIR)$(HTMLDIR)/$$dir; then \
+ if test -d $(top_srcdir)/html/$$dir; then \
+ cd $(top_srcdir)/html/$$dir; \
+ if test -d $(DESTDIR)$(HTMLDIR)/$$dir; then \
:; \
- else \
+ else \
$(mkdir_p) $(DESTDIR)$(HTMLDIR)/$$dir; \
- fi; \
- for file in *.html; do \
+ fi; \
+ for file in *.html; do \
${INSTALL} -m 644 $$file $(DESTDIR)$(HTMLDIR)/$$dir/$$file; \
- done; \
- cd $$here; \
+ done; \
+ if test -r $$top_srcdir/xml/$$dir/symlinks; then \
+ grep -v '^[ \t]*[;#]' $$top_srcdir/xml/$$dir/symlinks | \
+ sed 's,^/,_,;s,\\.\\./,__/,g' | \
+ while read S T; do ln -sf $$S $$T; done; \
+ fi; \
+ cd $$here; \
+ fi; \
done
install-data-local: install-html

Return to:

Send suggestions and report system problems to the System administrator.