aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2004-03-08 17:49:39 +0000
committerSergey Poznyakoff <gray@gnu.org.ua>2004-03-08 17:49:39 +0000
commit23030b10e3b9335ae5dc0384a2cb2890cf3685ac (patch)
treeca3e765a20e6da33cb24d1c9871987dd7e7ee756 /Makefile.am
parent1a63a918f80858a329f0312da04a6a2ea37011d0 (diff)
downloadellinika-23030b10e3b9335ae5dc0384a2cb2890cf3685ac.tar.gz
ellinika-23030b10e3b9335ae5dc0384a2cb2890cf3685ac.tar.bz2
New files
git-svn-id: file:///home/puszcza/svnroot/ellinika/trunk@27 941c8c0f-9102-463b-b60b-cd22ce0e6858
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..c4fa7a6
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,26 @@
+AUTOMAKE_OPTIONS = gnits 1.8
+ACLOCAL_AMFLAGS = -I m4
+
+SUBDIRS=cgi-bin data src xml xtrans po
+
+# FIXME
+EXTRANS=python /home/gray/eXtrans/extrans.py
+all-local:
+ -BASE_HREF="$(BASE_HREF)" TARGET_DIR="$(TARGET_DIR)" $(EXTRANS) $(top_srcdir)/lingua.xtrans
+
+install-html:
+ for dir in ru el; do \
+ here=`pwd`; \
+ cd $(top_srcdir)/html/$$dir; \
+ if test -d $(DESTDIR)$(HTMLDIR)/$$dir; then \
+ : \
+ else \
+ $(mkdir_p) $(DESTDIR)$(HTMLDIR)/$$dir; \
+ fi; \
+ for file in *.html; do \
+ ${INSTALL} -m 644 $$file $(DESTDIR)$(HTMLDIR)/$$dir/$$file; \
+ done; \
+ cd $$here; \
+ done
+
+install-data-local: install-html

Return to:

Send suggestions and report system problems to the System administrator.