aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index a16aff8..b5f7912 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -20,6 +20,7 @@ eclat_SOURCES=\
accfile.c\
cmdline.h\
config.c\
+ descrtags.c\
diag.c\
eclat.c\
eclat.h\
@@ -35,10 +36,15 @@ AM_CPPFLAGS= \
-DDEFAULT_PREPROCESSOR="$(DEFAULT_PREPROCESSOR)"
BUILT_SOURCES=cmdline.h
-EXTRA_DIST=cmdline.opt
+EXTRA_DIST=cmdline.opt eclat.conf
SUFFIXES=.opt .c .h
.opt.h:
m4 -s $(top_srcdir)/grecs/build-aux/getopt.m4 $< | sed '1d' > $@
+install-data-local:
+ @test -z "$(DESTDIR)$(sysconfdir)" || $(mkdir_p) "$(DESTDIR)$(sysconfdir)"
+ @if [ -r $(DESTDIR)$(sysconfdir)/eclat.conf ]; then :; \
+ else ${INSTALL} -m 644 $(top_srcdir)/src/eclat.conf \
+ $(DESTDIR)$(sysconfdir)/eclat.conf; fi

Return to:

Send suggestions and report system problems to the System administrator.