aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac67
1 files changed, 67 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..c6384ab
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,67 @@
+# This file is part of Eclat -*- autoconf -*-
+# Copyright (C) 2012 Sergey Poznyakoff
+#
+# Eclat is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# Eclat is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with Eclat. If not, see <http://www.gnu.org/licenses/>.
+
+AC_PREREQ(2.63)
+AC_INIT([eclat], 0.1, [gray+eclat@gnu.org.ua])
+AC_CONFIG_SRCDIR([src/eclat.h])
+AC_CONFIG_AUX_DIR([build-aux])
+AC_CONFIG_HEADER([config.h])
+AM_INIT_AUTOMAKE([1.11 gnits tar-ustar dist-xz std-options silent-rules])
+dnl AC_CONFIG_LIBOBJ_DIR([src])
+
+# Enable silent rules by default:
+AM_SILENT_RULES([yes])
+
+# Checks for programs.
+AC_PROG_CC
+AC_PROG_RANLIB
+
+# Checks for header files.
+AC_HEADER_STDC
+AC_CHECK_HEADERS([getopt.h])
+
+# Check for libcurl
+AC_ARG_VAR([CURL_CONFIG],[pathname of the curl-config binary])
+AC_ARG_VAR([CURL_CFLAGS],[cc flags to use when compiling with libcurl])
+AC_ARG_VAR([CURL_LIBS],[curl libraries to link with])
+
+if test -z "$CURL_LIBS"; then
+ if test -z "$CURL_CONFIG"; then
+ AC_PATH_PROG(CURL_CONFIG, curl-config, none, $PATH)
+ fi
+ if test "$CURL_CONFIG" = "none"; then
+ AC_MSG_ERROR([cannot find libcurl])
+ fi
+ CURL_CFLAGS=`$CURL_CONFIG --cflags`
+ CURL_LIBS=`$CURL_CONFIG --libs`
+ # FIXME: Check curl version?
+fi
+
+# Grecs subsystem
+
+GRECS_SETUP([grecs],[tests getopt git2chg])
+
+# Initialize the test suite.
+AC_CONFIG_TESTDIR(tests)
+AC_CONFIG_FILES([tests/Makefile tests/atlocal])
+AM_MISSING_PROG([AUTOM4TE], [autom4te])
+
+AC_CONFIG_FILES([Makefile
+ lib/Makefile
+ src/Makefile])
+
+AC_OUTPUT
+

Return to:

Send suggestions and report system problems to the System administrator.