aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 8 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 5e5cc38..915e43a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,3 +1,3 @@
# This file is part of Eclat -*- autoconf -*-
-# Copyright (C) 2012-2021 Sergey Poznyakoff
+# Copyright (C) 2012-2023 Sergey Poznyakoff
#
@@ -16,4 +16,4 @@
-AC_PREREQ(2.63)
-AC_INIT([eclat], 2.1, [bug-eclat@gnu.org.ua],,
+AC_PREREQ([2.71])
+AC_INIT([eclat], [2.1.1], [bug-eclat@gnu.org.ua],[],
[http://www.gnu.org.ua/software/eclat])
@@ -21,3 +21,3 @@ AC_CONFIG_SRCDIR([src/eclat.h])
AC_CONFIG_AUX_DIR([build-aux])
-AC_CONFIG_HEADER([config.h])
+AC_CONFIG_HEADERS([config.h])
AM_INIT_AUTOMAKE([1.11 gnits tar-ustar dist-xz std-options silent-rules])
@@ -30,3 +30,3 @@ AM_SILENT_RULES([yes])
AC_PROG_CC
-AC_PROG_LEX
+AC_PROG_LEX([noyywrap])
AC_PROG_YACC
@@ -35,3 +35,2 @@ AC_PROG_RANLIB
# Checks for header files.
-AC_HEADER_STDC
AC_CHECK_HEADERS([getopt.h])
@@ -65,4 +64,3 @@ AC_SUBST([MAPLIBS])
AC_ARG_WITH([gdbm],
- [AC_HELP_STRING([--with-gdbm],
- [use GNU DBM])],
+ [AS_HELP_STRING([--with-gdbm],[use GNU DBM])],
[case "${withval}" in
@@ -90,4 +88,3 @@ AM_CONDITIONAL([COND_GDBM],[test $status_gdbm = yes])
AC_ARG_WITH(ldap,
- [AC_HELP_STRING([--with-ldap],
- [use OpenLDAP])],
+ [AS_HELP_STRING([--with-ldap],[use OpenLDAP])],
[case $withval in
@@ -120,4 +117,3 @@ GRECS_SETUP([grecs],[tests getopt json git2chg])
AC_ARG_ENABLE([split-format],
- [AC_HELP_STRING([--enable-split-format],
- [build split format files])],
+ [AS_HELP_STRING([--enable-split-format],[build split format files])],
[split_fmt=$enableval],

Return to:

Send suggestions and report system problems to the System administrator.