aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2012-09-20 11:48:40 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2012-09-20 11:48:40 +0300
commit205d53a8e930d3fd126075ab083d316cc344ebaf (patch)
tree5d6b196f3325032dd1924eff87d7d39fbe439198 /src/Makefile.am
parent575fd3cf1af350d7ed0b661e0b8b177e3b387da7 (diff)
downloadeclat-205d53a8e930d3fd126075ab083d316cc344ebaf.tar.gz
eclat-205d53a8e930d3fd126075ab083d316cc344ebaf.tar.bz2
Require libexpat, implement DescribeTags.
* configure.ac: Require libexpat * src/descrtags.c: New file. * src/Makefile.am: Add new files. * src/accfile.c (access_file_lookup): Bugfix (stripped the first byte from the returned access_key). * src/cmdline.opt: New option --describe-tags * src/eclat.c: Register eclat_describe_tags handler. * src/eclat.h: Include expat.h (dry_run_mode): New extern. (eclat_command_describe_tags): New command code. (eclat_describe_tags): New proto. * src/startinst.c: More debugging info. Implement dry-run,
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index a16aff8..b5f7912 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -22,2 +22,3 @@ eclat_SOURCES=\
config.c\
+ descrtags.c\
diag.c\
@@ -37,3 +38,3 @@ AM_CPPFLAGS= \
BUILT_SOURCES=cmdline.h
-EXTRA_DIST=cmdline.opt
+EXTRA_DIST=cmdline.opt eclat.conf
@@ -44 +45,6 @@ SUFFIXES=.opt .c .h
+install-data-local:
+ @test -z "$(DESTDIR)$(sysconfdir)" || $(mkdir_p) "$(DESTDIR)$(sysconfdir)"
+ @if [ -r $(DESTDIR)$(sysconfdir)/eclat.conf ]; then :; \
+ else ${INSTALL} -m 644 $(top_srcdir)/src/eclat.conf \
+ $(DESTDIR)$(sysconfdir)/eclat.conf; fi

Return to:

Send suggestions and report system problems to the System administrator.