aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2012-09-19 11:28:28 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2012-09-19 18:30:01 +0300
commit1153970626892573e5966e135e8d81185f4ea53c (patch)
tree773fdf5a8d00ec2ef752c3a8fd5f32c79829cf23 /src/Makefile.am
downloadeclat-1153970626892573e5966e135e8d81185f4ea53c.tar.gz
eclat-1153970626892573e5966e135e8d81185f4ea53c.tar.bz2
Initial commit
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am44
1 files changed, 44 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..a16aff8
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,44 @@
+# This file is part of Eclat
+# Copyright (C) 2012 Sergey Poznyakoff
+#
+# Eclat is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# Eclat is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with Eclat. If not, see <http://www.gnu.org/licenses/>.
+
+bin_PROGRAMS=eclat
+
+eclat_SOURCES=\
+ accfile.c\
+ cmdline.h\
+ config.c\
+ diag.c\
+ eclat.c\
+ eclat.h\
+ startinst.c
+
+AM_LDFLAGS = $(CURL_LIBS)
+LDADD=../lib/libeclat.a @LIBOBJS@ ../grecs/src/libgrecs.a
+INCLUDES = -I$(top_srcdir)/grecs/src/ -I$(top_srcdir)/lib $(CURL_CFLAGS)
+AM_CPPFLAGS= \
+ -DSYSCONFDIR=\"$(sysconfdir)\"\
+ -DDEFAULT_VERSION_INCLUDE_DIR=\"$(incdir)\"\
+ -DDEFAULT_INCLUDE_DIR=\"$(pkgdatadir)/include\"\
+ -DDEFAULT_PREPROCESSOR="$(DEFAULT_PREPROCESSOR)"
+
+BUILT_SOURCES=cmdline.h
+EXTRA_DIST=cmdline.opt
+
+SUFFIXES=.opt .c .h
+
+.opt.h:
+ m4 -s $(top_srcdir)/grecs/build-aux/getopt.m4 $< | sed '1d' > $@
+

Return to:

Send suggestions and report system problems to the System administrator.