aboutsummaryrefslogtreecommitdiff
path: root/etc/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2012-09-30 18:38:09 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2012-09-30 18:38:09 +0300
commite3060ee47d58dac8827288614aaa86d5ad40e0ff (patch)
tree7e50e101a2ede83ae03def7617fa6ce5faface35 /etc/Makefile.am
parent1de5ac257cb92f45f585e1a17b7cd7d2c5b7203c (diff)
downloadeclat-e3060ee47d58dac8827288614aaa86d5ad40e0ff.tar.gz
eclat-e3060ee47d58dac8827288614aaa86d5ad40e0ff.tar.bz2
Implement the describe-volumes command.
* etc/Makefile.am (FLNFILES): Add describe-volumes.fln (install-formats): New rule. * etc/describe-volumes.fln: New file. * src/Makefile.am (eclat_SOURCES): Add dscrvols.c (AM_LDFLAGS): Remove. (LDADD): Add $(CURL_LIBS) * src/accfile.c (get_access_creds): Minor changes. * src/cmdline.opt: New option --format-expression. * src/dscrinsts.c: Minor change. * src/dscrvols.c: New file. * src/eclat.c: New command "describe-volumes". * src/eclat.h (eclat_describe_volumes): New proto. * tests/describe-volumes.at: New file. * tests/Makefile.am: Add new file. * tests/testsuite.at: Include new file.
Diffstat (limited to 'etc/Makefile.am')
-rw-r--r--etc/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/etc/Makefile.am b/etc/Makefile.am
index 8539e93..7c852c4 100644
--- a/etc/Makefile.am
+++ b/etc/Makefile.am
@@ -23,6 +23,7 @@ FLNFILES=\
describe-instance-status.fln\
describe-instances.fln\
describe-tags.fln\
+ describe-volumes.fln\
start-instances.fln\
stop-instances.fln
@@ -51,6 +52,12 @@ CLEANFILES=eclat.conf $(FORMATFILES)
.cfin.conf:
$(AM_V_GEN)sed 's^FORMATDIR^$(formatdir)^;s^FORMATNAME^$(FORMATNAME)^' $< > $@
+install-formats: $(FORMATFILES)
+ ${INSTALL} -d $(DESTDIR)$(formatdir); \
+ for file in $(FORMATFILES); do \
+ ${INSTALL} -m 644 $$file $(DESTDIR)$(formatdir)/$$file; \
+ done
+
install-data-local:
@test -z "$(DESTDIR)$(sysconfdir)" || $(mkdir_p) "$(DESTDIR)$(sysconfdir)"
@if [ -r $(DESTDIR)$(sysconfdir)/eclat.conf ]; then :; \

Return to:

Send suggestions and report system problems to the System administrator.