aboutsummaryrefslogtreecommitdiff
path: root/etc/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org>2013-12-03 15:32:12 +0200
committerSergey Poznyakoff <gray@gnu.org>2013-12-03 15:32:12 +0200
commit5e501cf05fd1997018613304761d1104879353aa (patch)
treefd14fa84bf80b72e8472f8451639e33501afe886 /etc/Makefile.am
parent495c4a5cadf67b7c9b5e0c8b224f7b68c42c8da4 (diff)
downloadeclat-5e501cf05fd1997018613304761d1104879353aa.tar.gz
eclat-5e501cf05fd1997018613304761d1104879353aa.tar.bz2
Implement sg --list
* etc/Makefile.am (FLNFILES): Add lsattr.fln (.fln.forlan): Use all prerequisites, not only the first one. (FORMATFILES): Remove lsattr.forlan (lsattr.forlan): Use implicit rule. (sg.forlan): New rule * etc/flncat.c (comment): Optionally output the comment. (main): Output " else " only if some non-whitespace and non-comment characters were output before. * etc/lsattr.fln: New file * src/sg-cl.opt: New option --list. * src/sg.c (list_option): New variable.
Diffstat (limited to 'etc/Makefile.am')
-rw-r--r--etc/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/etc/Makefile.am b/etc/Makefile.am
index 1f53924..caa780c 100644
--- a/etc/Makefile.am
+++ b/etc/Makefile.am
@@ -45,6 +45,7 @@ FLNFILES=\
detach-volume.fln\
disassociate-address.fln\
get-console-output.fln\
+ lsattr.fln\
modify-instance-attribute.fln\
modify-snapshot-attribute.fln\
reboot-instances.fln\
@@ -62,11 +63,11 @@ SUFFIXES=.cfin .conf
if SPLIT_FORMATS
SUFFIXES += .forlan .fln
.fln.forlan:
- $(AM_V_GEN)$(abs_builddir)/flncat $< default.fln > $@
-FORMATFILES = $(FLNFILES:.fln=.forlan) lsattr.forlan
+ $(AM_V_GEN)$(abs_builddir)/flncat $^ default.fln > $@
+FORMATFILES = $(FLNFILES:.fln=.forlan)
FORMATNAME = $${command}
-lsattr.forlan: describe-instance-attribute.fln describe-snapshot-attribute.fln default.fln
- $(AM_V_GEN)(cd $(srcdir); $(abs_builddir)/flncat describe-instance-attribute.fln describe-snapshot-attribute.fln default.fln) > lsattr.forlan
+lsattr.forlan: describe-instance-attribute.fln describe-snapshot-attribute.fln default.fln
+sg.forlan: sg.fln describe-security-groups.fln
else
FORMATFILES = eclat.forlan
eclat.forlan: $(FLNFILES) default.fln

Return to:

Send suggestions and report system problems to the System administrator.