aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2012-09-28 11:23:09 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2012-09-28 11:32:04 +0300
commitac1d6cbbcf5323d5db59886b98a24c45bafa64b8 (patch)
treef2a77092e072faa680b47d9d6d960e7214e46876 /Makefile.am
parentd902742081bc31a6eda274268da0178107e4abb4 (diff)
downloadeclat-ac1d6cbbcf5323d5db59886b98a24c45bafa64b8.tar.gz
eclat-ac1d6cbbcf5323d5db59886b98a24c45bafa64b8.tar.bz2
Improve testsuite. Reorganize directory structure.
* Makefile.am (SUBDIRS): Add etc (distuninstallcheck_listfiles): Ignore *.forlan files. * configure.ac: New options --split-format and --format-dir * etc/Makefile.am: New file. * etc/default.fln: New file. * etc/describe-instance-status.fln: New file. * etc/describe-instances.fln: New file. * etc/describe-tags.fln: New file. * etc/eclat.cfin: New file. * etc/flncat.c: New file. * etc/start-instances.fln: New file. * etc/stop-instances.fln: New file. * src/Makefile.am: Remove eclat.conf. It is built in /etc now. * src/eclat.conf: Remove. * src/cmdline.opt: Update. * src/config.c: New configuration statement "format-file". * src/eclat.c (format_file_option): New global. (main): Read format from format-file, if supplied. Expand keywords in its argument. * src/eclat.h (format_file_option): New extern. * tests/.gitignore: Update. * tests/Makefile.am: Add new files. * tests/describe-instance-status.at: New test case. * tests/describe-instances.at: New test case. * tests/describe-tags.at: New test case. * tests/dscrinststat.at: New test case. * tests/start-instances.at: New test case. * tests/stop-instances.at: New test case. * tests/testsuite.at (ECLAT_TEST_FORMAT): New macro. Include new test cases. * tests/trws.c: New file.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 171250b..d78d1f6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,7 +16,7 @@
ACLOCAL_AMFLAGS = -I grecs/am
-SUBDIRS = grecs lib src tests
+SUBDIRS = grecs lib src etc tests
.PHONY: ChangeLog
ChangeLog:
@@ -25,4 +25,4 @@ ChangeLog:
awk -f $(top_srcdir)/grecs/build-aux/git2chg.awk > ChangeLog; \
fi
-distuninstallcheck_listfiles = find . -type f -not -name 'eclat.conf' -print
+distuninstallcheck_listfiles = find . -type f -not -name 'eclat.conf' -not -name '*.forlan' -print

Return to:

Send suggestions and report system problems to the System administrator.