aboutsummaryrefslogtreecommitdiff
path: root/dgd/Makefile.PL
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2015-05-18 14:33:22 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2015-05-18 15:40:56 +0300
commiteb851ae32ee068dd368a8cb6db9b04e526316643 (patch)
tree656a221a10f8d833b2efca4376795a51dc825933 /dgd/Makefile.PL
parentd3b66f2187296695b948ef7764b76ff8f064ce4f (diff)
downloaddnstools-eb851ae32ee068dd368a8cb6db9b04e526316643.tar.gz
dnstools-eb851ae32ee068dd368a8cb6db9b04e526316643.tar.bz2
New sub-package: dgd
Diffstat (limited to 'dgd/Makefile.PL')
-rw-r--r--dgd/Makefile.PL38
1 files changed, 38 insertions, 0 deletions
diff --git a/dgd/Makefile.PL b/dgd/Makefile.PL
new file mode 100644
index 0000000..0f418f2
--- /dev/null
+++ b/dgd/Makefile.PL
@@ -0,0 +1,38 @@
+# -*- perl -*-
+# Copyright (C) 2015 Sergey Poznyakoff <gray@gnu.org>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+use lib 'inc';
+use ExtUtils::AutoInstall (
+ -core => [
+ 'Getopt::Long' => 2.34,
+ 'Pod::Usage' => 1.51,
+ 'Pod::Man' => 2.25,
+ 'Net::Ping' => 2.38,
+ 'Proc::Daemon' => 0.19,
+ 'Data::Dumper' => 2.135
+ ]
+);
+
+# See lib/ExtUtils/MakeMaker.pm for details of how to influence
+# the contents of the Makefile that is written.
+WriteMakefile(
+ 'NAME' => 'dgd',
+ 'AUTHOR' => 'Sergey Poznyakoff <gray@gnu.org>',
+ 'ABSTRACT' => 'Dead gateway detector',
+ 'FIRST_MAKEFILE' => 'Makefile',
+ 'VERSION' => '1.00',
+ 'EXE_FILES' => [ 'dgd' ],
+);

Return to:

Send suggestions and report system problems to the System administrator.