aboutsummaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 47f481f..61146b5 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -30,11 +30,17 @@ endif
EXTRA_DIST = gendocs.sh gendocs_template mt.1 rmt.8
GENDOCS=$(srcdir)/gendocs.sh
+TEXI2DVI=texi2dvi -E
# Make sure you set TEXINPUT
manual:
rm -rf manual
TEXINPUTS=$(srcdir):$(top_srcdir)/scripts:$$TEXINPUTS \
MAKEINFO="$(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS)" \
- TEXI2DVI="texi2dvi -t @finalout" \
- $(GENDOCS) --no-copy-images $(PACKAGE) '$(PACKAGE_NAME) manual'
+ TEXI2DVI="texi2dvi -t '@set DISTRIB' -t @finalout" \
+ $(GENDOCS) --texi2html $(PACKAGE) '$(PACKAGE_NAME) manual'
+
+manual-rebuild: clean-local manual
+
+clean-local:
+ rm -rf manual

Return to:

Send suggestions and report system problems to the System administrator.