aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2004-02-27 13:28:40 +0000
committerSergey Poznyakoff <gray@gnu.org.ua>2004-02-27 13:28:40 +0000
commita783e2c18c6b566b2f4c2b06e6c388a9645c826c (patch)
treeae12abc157dee99bd4c67bab25316be06d3519a2 /src/Makefile.am
parentcb721df9888a296af824a4acab4916694d6dc35d (diff)
downloadcpio-a783e2c18c6b566b2f4c2b06e6c388a9645c826c.tar.gz
cpio-a783e2c18c6b566b2f4c2b06e6c388a9645c826c.tar.bz2
Added to the repository
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am81
1 files changed, 81 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..1e5da40
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,81 @@
+# This file is part of GNU cpio
+# Copyright (C) 2003, 2004 Free Software Foundation, Inc.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2, or (at your option)
+# any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+bin_PROGRAMS=cpio @CPIO_MT_PROG@
+libexec_PROGRAMS=@CPIO_RMT_PROG@
+EXTRA_PROGRAMS=mt rmt
+
+cpio_SOURCES = \
+ copyin.c\
+ copyout.c\
+ copypass.c\
+ defer.c\
+ dstring.c\
+ global.c\
+ main.c\
+ tar.c\
+ util.c\
+ error.c\
+ filemode.c\
+ dirname.c\
+ idcache.c\
+ makepath.c\
+ xmalloc.c\
+ stripslash.c\
+ userspec.c\
+ xstrdup.c
+
+noinst_HEADERS =\
+ cpio.h\
+ cpiohdr.h\
+ tar.h\
+ tarhdr.h\
+ defer.h\
+ dstring.h\
+ extern.h\
+ filetypes.h\
+ gettext.h\
+ system.h\
+ rmt.h\
+ safe-stat.h\
+ fnmatch.h\
+ getopt.h
+
+cpio_LDADD = @LIBOBJS@
+
+mt_SOURCES = \
+ mt.c argmatch.c
+mt_LDADD = @LIBOBJS@
+
+rmt_SOURCES = rmt.c
+rmt_LDADD = @LIBOBJS@
+
+EXTRA_DIST=\
+ getopt.c\
+ getopt1.c\
+ bcopy.c\
+ fnmatch.c\
+ mkdir.c\
+ strdup.c
+
+localedir = $(datadir)/locale
+
+DISTCLEANFILES = localedir.h
+localedir.h : Makefile
+ echo '#define LOCALEDIR "$(localedir)"' >$@
+
+mt.o main.o: localedir.h

Return to:

Send suggestions and report system problems to the System administrator.