aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2003-11-21 14:46:17 +0000
committerSergey Poznyakoff <gray@gnu.org.ua>2003-11-21 14:46:17 +0000
commit29660fa1dc74f1ec8b7965f886779bc2b37d78a5 (patch)
treeac615dcc160b16e434a304d4216ae128c1547104 /Makefile.am
parent3342ad4d2a64a34ba8d9295494da0770655b9f46 (diff)
downloadcpio-29660fa1dc74f1ec8b7965f886779bc2b37d78a5.tar.gz
cpio-29660fa1dc74f1ec8b7965f886779bc2b37d78a5.tar.bz2
Added to the repository
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am71
1 files changed, 71 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..8e32b1a
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,71 @@
+# This file is part of GNU cpio
+# Copyright (C) 2003 Free Software Foundation, Inc.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2, or (at your option)
+# any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+bin_PROGRAMS=cpio @CPIO_MT_PROG@
+libexec_PROGRAMS=@CPIO_RMT_PROG@
+EXTRA_PROGRAMS=mt rmt
+
+cpio_SOURCES = \
+ copyin.c\
+ copyout.c\
+ copypass.c\
+ defer.c\
+ dstring.c\
+ global.c\
+ main.c\
+ tar.c\
+ util.c\
+ error.c\
+ filemode.c\
+ dirname.c\
+ idcache.c\
+ makepath.c\
+ xmalloc.c\
+ stripslash.c\
+ userspec.c\
+ xstrdup.c
+
+noinst_HEADERS =\
+ cpio.h\
+ cpiohdr.h\
+ tar.h\
+ tarhdr.h\
+ defer.h\
+ dstring.h\
+ extern.h\
+ filetypes.h\
+ system.h\
+ rmt.h\
+ safe-stat.h\
+ fnmatch.h\
+ getopt.h
+
+cpio_LDADD = @LIBOBJS@
+
+mt_SOURCES = \
+ mt.c argmatch.c
+mt_LDADD = @LIBOBJS@
+
+rmt_SOURCES = rmt.c
+
+EXTRA_DIST=\
+ getopt.c\
+ getopt1.c\
+ bcopy.c\
+ fnmatch.c\
+ mkdir.c\
+ strdup.c

Return to:

Send suggestions and report system problems to the System administrator.