aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..7702ede
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,34 @@
+SUBDIRS=. lib examples doc
+noinst_SCRIPTS=build.sed backup.sh restore.sh
+CLEANFILES=backup.sh restore.sh
+install-exec-hook:
+ for file in backup restore; \
+ do \
+ test -z "$(DESTDIR)$(bindir)" || \
+ $(mkdir_p) "$(DESTDIR)$(bindir)"; \
+ ${INSTALL} $(top_builddir)/$$file.sh \
+ $(DESTDIR)$(bindir)/$$file; \
+ done
+install-data-hook:
+ test -z "$(DESTDIR)$(sysconfdir)" || \
+ $(mkdir_p) "$(DESTDIR)$(sysconfdir)"; \
+ if test -f $(DESTDIR)$(sysconfdir)/backup.conf; then :; else \
+ ${INSTALL} -m 644 $(top_srcdir)/backup.conf $(DESTDIR)$(sysconfdir);\
+ fi
+uninstall-hook:
+ for file in backup restore; \
+ do \
+ rm -f "$(DESTDIR)$(bindir)/$$file"; \
+ done
+backup.sh restore.sh: build.sed
+EXTRA_DIST=backup.in restore.in backup.conf
+distuninstallcheck_listfiles=find $(DESTDIR)$(prefix) -type f -not -wholename '$(DESTDIR)$(sysconfdir)/backup.conf'
+
+$(top_builddir)/build.sed: Makefile
+ $(AM_V_GEN){ \
+ echo 's|@''SYSCONFDIR''@|${sysconfdir}|g';\
+ echo 's|@''LIBDIR''@|${libdir}|g'; \
+ echo 's|@''BINDIR''@|${bindir}|g'; \
+ } > $(top_builddir)/build.sed
+DISTCLEANFILES=build.sed backup.sh restore.sh
+include $(top_srcdir)/Make.rules

Return to:

Send suggestions and report system problems to the System administrator.