aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am73
1 files changed, 0 insertions, 73 deletions
diff --git a/Makefile.am b/Makefile.am
deleted file mode 100644
index 551f7b2..0000000
--- a/Makefile.am
+++ /dev/null
@@ -1,73 +0,0 @@
-# This file is part of BEAM
-# Copyright (C) 2012-2014 Sergey Poznyakoff
-#
-# BEAM is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 3, or (at your option)
-# any later version.
-#
-# BEAM is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with BEAM. If not, see <http://www.gnu.org/licenses/>.
-SUBDIRS=. lib doc
-if COND_S3MOUNT
- S3MOUNT=s3
- S3MOUNT_SH=s3.sh
-endif
-noinst_SCRIPTS=build.sed backup.sh restore.sh cleaner.sh list.sh $(S3MOUNT_SH)
-bin_SCRIPTS=beam
-CLEANFILES=beam beam.sh backup.sh restore.sh cleaner.sh list.sh $(S3MOUNT_SH)
-install-exec-hook:
- test -z "$(DESTDIR)$(libexecdir)" || \
- $(mkdir_p) "$(DESTDIR)$(libexecdir)"; \
- for file in backup restore cleaner list $(S3MOUNT); \
- do \
- ${INSTALL} $(top_builddir)/$$file.sh \
- $(DESTDIR)$(libexecdir)/beam-$$file; \
- done
-install-data-hook:
- test -z "$(DESTDIR)$(sysconfdir)" || \
- $(mkdir_p) "$(DESTDIR)$(sysconfdir)"; \
- if test -f $(DESTDIR)$(sysconfdir)/beam.conf; then :; else \
- ${INSTALL} -m 644 $(top_srcdir)/beam.conf $(DESTDIR)$(sysconfdir);\
- fi
-uninstall-hook:
- for file in backup restore cleaner list $(S3MOUNT); \
- do \
- rm -f "$(DESTDIR)$(libexecdir)/beam-$$file"; \
- done
-beam.sh backup.sh restore.sh cleaner.sh list.sh $(S3MOUNT_SH): build.sed
-EXTRA_DIST=beam.in backup.in restore.in beam.conf cleaner.in list.in s3.in
-distuninstallcheck_listfiles=find $(DESTDIR)$(prefix) -type f -not -wholename '$(DESTDIR)$(sysconfdir)/beam.conf'
-
-$(top_builddir)/build.sed: Makefile
- $(AM_V_GEN){ \
- echo 's|@''SYSCONFDIR''@|${sysconfdir}|g';\
- echo 's|@''LIBDIR''@|${libdir}|g'; \
- echo 's|@''BINDIR''@|${bindir}|g'; \
- echo 's|@''LIBEXECDIR''@|${libexecdir}|g'; \
- echo 's|@''LOCALSTATEDIR''@|${localstatedir}|g'; \
- echo 's|@''DATAROOTDIR''@|${datarootdir}|g'; \
- echo 's|@''PACKAGE_BUGREPORT''@|$(PACKAGE_BUGREPORT)|g'; \
- echo 's|@''PACKAGE_NAME''@|$(PACKAGE_NAME)|g';\
- echo 's|@''PACKAGE_STRING''@|$(PACKAGE_STRING)|g';\
- echo 's|@''PACKAGE_TARNAME''@|$(PACKAGE_STRING)|g';\
- echo 's|@''PACKAGE_URL''@|$(PACKAGE_URL)|g';\
- echo 's|@''PACKAGE_VERSION''@|$(PACKAGE_VERSION)|g';\
- } > $(top_builddir)/build.sed
-DISTCLEANFILES=build.sed backup.sh restore.sh list.sh
-include $(top_srcdir)/Make.rules
-
-.PHONY: ChangeLog
-ChangeLog:
- $(AM_V_GEN)if test -d .git; then \
- git log --pretty='format:%ct %an <%ae>%n%n%s%n%n%b%n' | \
- awk -f $(top_srcdir)/git2chg.awk > ChangeLog.tmp; \
- cmp ChangeLog ChangeLog.tmp > /dev/null 2>&1 || \
- mv ChangeLog.tmp ChangeLog; \
- rm -f ChangeLog.tmp; \
- fi

Return to:

Send suggestions and report system problems to the System administrator.