aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2012-07-04 13:30:27 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2012-07-04 13:30:27 +0300
commitccb9742c80519ef29d2a529397011dd718613005 (patch)
treef9d1df7ca884f0c4570bb2573023a9c4f1a0fd2b /Makefile.am
parent919b830afdd005d5b3c5af7004af0d85599e4ae1 (diff)
downloadbeam-ccb9742c80519ef29d2a529397011dd718613005.tar.gz
beam-ccb9742c80519ef29d2a529397011dd718613005.tar.bz2
Implement list command.
* list.in: New file. * .gitignore: Add list.sh * Makefile.am: Build and install list.sh * lib/beam/fs.sh: Implement list method. * lib/beam/mysql.sh: Likewise. * lib/beam/postgres.sh: Likewise.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 685624c..3a5be3f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,13 +3,13 @@ if COND_S3MOUNT
S3MOUNT=s3
S3MOUNT_SH=s3.sh
endif
-noinst_SCRIPTS=build.sed backup.sh restore.sh cleaner.sh $(S3MOUNT_SH)
+noinst_SCRIPTS=build.sed backup.sh restore.sh cleaner.sh list.sh $(S3MOUNT_SH)
bin_SCRIPTS=beam
-CLEANFILES=beam beam.sh backup.sh restore.sh cleaner.sh $(S3MOUNT_SH)
+CLEANFILES=beam beam.sh backup.sh restore.sh cleaner.sh list.sh $(S3MOUNT_SH)
install-exec-hook:
test -z "$(DESTDIR)$(libexecdir)" || \
$(mkdir_p) "$(DESTDIR)$(libexecdir)"; \
- for file in backup restore cleaner $(S3MOUNT); \
+ for file in backup restore cleaner list $(S3MOUNT); \
do \
${INSTALL} $(top_builddir)/$$file.sh \
$(DESTDIR)$(libexecdir)/beam-$$file; \
@@ -21,12 +21,12 @@ install-data-hook:
${INSTALL} -m 644 $(top_srcdir)/beam.conf $(DESTDIR)$(sysconfdir);\
fi
uninstall-hook:
- for file in backup restore cleaner $(S3MOUNT); \
+ for file in backup restore cleaner list $(S3MOUNT); \
do \
rm -f "$(DESTDIR)$(libexecdir)/beam-$$file"; \
done
-beam.sh backup.sh restore.sh cleaner.sh $(S3MOUNT_SH): build.sed
-EXTRA_DIST=beam.in backup.in restore.in beam.conf cleaner.in s3.in
+beam.sh backup.sh restore.sh cleaner.sh list.sh $(S3MOUNT_SH): build.sed
+EXTRA_DIST=beam.in backup.in restore.in beam.conf cleaner.in list.in s3.in
distuninstallcheck_listfiles=find $(DESTDIR)$(prefix) -type f -not -wholename '$(DESTDIR)$(sysconfdir)/beam.conf'
$(top_builddir)/build.sed: Makefile
@@ -44,7 +44,7 @@ $(top_builddir)/build.sed: Makefile
echo 's|@''PACKAGE_URL''@|$(PACKAGE_URL)|g';\
echo 's|@''PACKAGE_VERSION''@|$(PACKAGE_VERSION)|g';\
} > $(top_builddir)/build.sed
-DISTCLEANFILES=build.sed backup.sh restore.sh
+DISTCLEANFILES=build.sed backup.sh restore.sh list.sh
include $(top_srcdir)/Make.rules
.PHONY: ChangeLog

Return to:

Send suggestions and report system problems to the System administrator.