aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2012-05-28 18:37:26 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2012-05-28 18:46:14 +0300
commit8ceb3484f218d25e025deb618ae3d202e2599dab (patch)
tree21b551664e24a420d1c967ace2144ee12f3adecd /Makefile.am
parent74940a305bb009a690e56d6d6562b3fd24269ae0 (diff)
downloadbeam-8ceb3484f218d25e025deb618ae3d202e2599dab.tar.gz
beam-8ceb3484f218d25e025deb618ae3d202e2599dab.tar.bz2
Incorporate s3 support. Change hook handling.
(Additionally: mysql.sh has been tested.) * .gitignore: Add s3mount.sh * Makefile.am: Build and install s3mount (conditionally). * backup-cleanup: Rename to backup-cleaner. * backup.conf (backup_retain_interval) (backup_bucket_name,backup_mp_s3backer) (backup_mp_s3): New variables. * backup.in: Change hook handling: each hook is a list of commands which are executed in succession. New option --version (-V). Run backup-cleaner if backup_retain_interval is set. * restore.in: Change hook handling. New option --version (-V). * configure.ac: Change version to 1.1. New option --with-s3. * doc/backup.conf.5in: Document new variables and changes in the hook handling. * examples/.gitignore: Remove. * examples/Makefile.am: Remove s3mount. * examples/s3mount.in: Remove. * lib/backup/Makefile.am (libbackup_SCRIPTS, EXTRA_DIST): Add s3.sh * lib/backup/common.in: Source backup/s3 if backup_bucket_name is set. (runhook,print_version): New function. * lib/backup/s3.sh: New file. * s3mount.in: New file.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am24
1 files changed, 17 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index e86de86..f3569b8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,9 +1,13 @@
SUBDIRS=. lib examples doc
-noinst_SCRIPTS=build.sed backup.sh restore.sh
-bin_SCRIPTS=backup-cleanup
-CLEANFILES=backup.sh restore.sh
+if COND_S3MOUNT
+ S3MOUNT=s3mount
+ S3MOUNT_SH=s3mount.sh
+endif
+noinst_SCRIPTS=build.sed backup.sh restore.sh $(S3MOUNT_SH)
+bin_SCRIPTS=backup-cleaner
+CLEANFILES=backup.sh restore.sh $(S3MOUNT_SH)
install-exec-hook:
- for file in backup restore; \
+ for file in backup restore $(S3MOUNT); \
do \
test -z "$(DESTDIR)$(bindir)" || \
$(mkdir_p) "$(DESTDIR)$(bindir)"; \
@@ -17,12 +21,12 @@ install-data-hook:
${INSTALL} -m 644 $(top_srcdir)/backup.conf $(DESTDIR)$(sysconfdir);\
fi
uninstall-hook:
- for file in backup restore; \
+ for file in backup restore $(S3MOUNT); \
do \
rm -f "$(DESTDIR)$(bindir)/$$file"; \
done
-backup.sh restore.sh: build.sed
-EXTRA_DIST=backup.in restore.in backup.conf backup-cleanup
+backup.sh restore.sh $(S3MOUNT_SH): build.sed
+EXTRA_DIST=backup.in restore.in backup.conf backup-cleaner s3mount.in
distuninstallcheck_listfiles=find $(DESTDIR)$(prefix) -type f -not -wholename '$(DESTDIR)$(sysconfdir)/backup.conf'
$(top_builddir)/build.sed: Makefile
@@ -30,6 +34,12 @@ $(top_builddir)/build.sed: Makefile
echo 's|@''SYSCONFDIR''@|${sysconfdir}|g';\
echo 's|@''LIBDIR''@|${libdir}|g'; \
echo 's|@''BINDIR''@|${bindir}|g'; \
+ echo 's|@''PACKAGE_BUGREPORT''@|$(PACKAGE_BUGREPORT)|g'; \
+ echo 's|@''PACKAGE_NAME''@|$(PACKAGE_NAME)|g';\
+ echo 's|@''PACKAGE_STRING''@|$(PACKAGE_STRING)|g';\
+ echo 's|@''PACKAGE_TARNAME''@|$(PACKAGE_STRING)|g';\
+ echo 's|@''PACKAGE_URL''@|$(PACKAGE_URL)|g';\
+ echo 's|@''PACKAGE_VERSION''@|$(PACKAGE_VERSION)|g';\
} > $(top_builddir)/build.sed
DISTCLEANFILES=build.sed backup.sh restore.sh
include $(top_srcdir)/Make.rules

Return to:

Send suggestions and report system problems to the System administrator.