aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL11
1 files changed, 6 insertions, 5 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 43555f8..0d093a8 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -1,13 +1,12 @@
# -*- perl -*-
use strict;
-use lib 'inc';
use Module::Metadata;
use Getopt::Long qw(:config gnu_getopt no_ignore_case pass_through);
use ExtUtils::MakeMaker;
my %makefile_args = (
NAME => 'App::Acmeman',
- ABSTRACT_FROM => 'acmeman',
+ ABSTRACT => 'manages ACME certificates',
VERSION_FROM => 'lib/App/Acmeman.pm',
AUTHOR => 'Sergey Poznyakoff <gray@gnu.org>',
LICENSE => 'gpl_3',
@@ -54,9 +53,11 @@ my %makefile_args = (
my $no_autoinstall;
GetOptions('no-autoinstall|N' => \$no_autoinstall) or exit(1);
unless ($no_autoinstall) {
- require ExtUtils::AutoInstall;
- ExtUtils::AutoInstall->import(-core => $makefile_args{PREREQ_PM});
- delete $makefile_args{PREREQ_PM};
+ eval {
+ require ExtUtils::AutoInstall;
+ ExtUtils::AutoInstall->import(-core => $makefile_args{PREREQ_PM});
+ delete $makefile_args{PREREQ_PM};
+ };
}
WriteMakefile(%makefile_args);

Return to:

Send suggestions and report system problems to the System administrator.