aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL35
1 files changed, 20 insertions, 15 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 01345dc..b8c8f8d 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -1,23 +1,28 @@
# -*- perl -*-
use strict;
-use ExtUtils::MakeMaker;
+use lib 'inc';
+use ExtUtils::AutoInstall (
+ -core => {
+ 'Getopt::Long' => 2.34,
+ 'File::Path' => 2.08,
+ 'File::Basename' => 2.84,
+ 'Protocol::ACME' => 1.01,
+ 'Protocol::ACME::Challenge::LocalFile' => 1.01,
+ 'Crypt::Format' => 0.06,
+ 'Crypt::OpenSSL::PKCS10' => 0.16,
+ 'Crypt::OpenSSL::RSA' => 0.28,
+ 'Crypt::OpenSSL::X509' => 1.807,
+ 'DateTime::Format::Strptime' => 1.42,
+ 'WWW::Curl::Easy' => 4.17,
+ 'Pod::Usage' => 1.51,
+ 'Pod::Man' => 2.25
+ }
+);
WriteMakefile(NAME => 'acmeman',
ABSTRACT_FROM => 'acmeman',
VERSION_FROM => 'acmeman',
AUTHOR => 'Sergey Poznyakoff <gray@gnu.org>',
LICENSE => 'gpl',
- EXE_FILES => [ 'acmeman' ],
- PREREQ_PM => { 'Getopt::Long' => 2.34,
- 'File::Path' => 2.08,
- 'File::Basename' => 2.84,
- 'Protocol::ACME' => 1.01,
- 'Protocol::ACME::Challenge::LocalFile' => 1.01,
- 'Crypt::Format' => 0.06,
- 'Crypt::OpenSSL::PKCS10' => 0.16,
- 'Crypt::OpenSSL::RSA' => 0.28,
- 'Crypt::OpenSSL::X509' => 1.807,
- 'DateTime::Format::Strptime' => 1.42,
- 'WWW::Curl::Easy' => 4.17,
- 'Pod::Usage' => 1.51,
- 'Pod::Man' => 2.25 } );
+ EXE_FILES => [ 'acmeman' ]
+);

Return to:

Send suggestions and report system problems to the System administrator.