aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2017-09-13 15:13:34 +0200
committerSergey Poznyakoff <gray@gnu.org.ua>2017-09-13 15:23:44 +0200
commit6599db656e097d8eb22921d2c2ce3451c8147563 (patch)
tree2b04a44ba67b088e0c62ac364c75b72ef928b8a9 /Makefile.PL
parent36f66056a4ddbba8f300ef2fd15955e292e2755f (diff)
downloadacmeman-6599db656e097d8eb22921d2c2ce3451c8147563.tar.gz
acmeman-6599db656e097d8eb22921d2c2ce3451c8147563.tar.bz2
Rewrite
This patch introduces acmeman configuration file, which can be used to direct its action if a server other than Apache is used. It also can be instructed to store certificate, certificate chain, and certificate key in a single file, instead of three different ones. This can be used with such servers as pound(8). In the absense of a configuration file, the program operates as in previous versions. * MANIFEST: Update. * Makefile.PL: Update. * Changes: Update. * acmeman: Use configuration file if present. Apache configuration remains as a default source of TLS domains. Configuration file can override or complement it. * lib/App/Acmeman/Domain.pm: New file. * lib/App/Acmeman/Config.pm: New file. * lib/App/Acmeman/Source/Apache.pm: New file. * lib/App/Acmeman/Apache/Layout.pm: New file.
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL25
1 files changed, 22 insertions, 3 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 1798216..edb81a9 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -1,11 +1,15 @@
# -*- perl -*-
use strict;
use lib 'inc';
+use Module::Metadata;
+
use ExtUtils::AutoInstall (
-core => {
'Getopt::Long' => 2.34,
'File::Path' => 2.08,
'File::Basename' => 2.84,
+ 'Test::NoWarnings' => 0,
+ 'Crypt::RSA::Parse' => 0.043,
'Protocol::ACME' => 1.01,
'Protocol::ACME::Challenge::LocalFile' => 1.01,
'Crypt::Format' => 0.06,
@@ -17,14 +21,29 @@ use ExtUtils::AutoInstall (
'LWP::Protocol::https' => 6.07,
'Pod::Usage' => 1.51,
'Pod::Man' => 2.25,
+ 'Text::ParseWords' => 3.27,
'Data::Dumper' => 0
}
);
-WriteMakefile(NAME => 'acmeman',
+WriteMakefile(NAME => 'App::Acmeman',
ABSTRACT_FROM => 'acmeman',
VERSION_FROM => 'acmeman',
AUTHOR => 'Sergey Poznyakoff <gray@gnu.org>',
- LICENSE => 'gpl',
- EXE_FILES => [ 'acmeman' ]
+ LICENSE => 'gpl_3',
+ EXE_FILES => [ 'acmeman' ],
+ MIN_PERL_VERSION => 5.006,
+ META_MERGE => {
+ 'meta-spec' => { version => 2 },
+ resources => {
+ repository => {
+ type => 'git',
+ url => 'git://git.gnu.org.ua/gsc/acmeman.git',
+ web => 'http://git.gnu.org.ua/cgit/gsc/acmeman.git/',
+ },
+ },
+ provides => Module::Metadata->provides(version => '1.4',
+ dir => 'lib')
+ }
+
);

Return to:

Send suggestions and report system problems to the System administrator.