aboutsummaryrefslogtreecommitdiff
path: root/etc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'etc/Makefile.am')
-rw-r--r--etc/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/etc/Makefile.am b/etc/Makefile.am
new file mode 100644
index 0000000..7fc8238
--- /dev/null
+++ b/etc/Makefile.am
@@ -0,0 +1,34 @@
+# This file is part of Wydawca
+# Copyright (C) 2007 Sergey Poznyakoff
+#
+# Wydawca is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# Wydawca is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with Wydawca. If not, see <http://www.gnu.org/licenses/>.
+
+EXTRA_DIST=wydawca.rc messages.rc
+
+install-data-local:
+ @test -d $(DESTDIR)$(sysconfdir) || \
+ ${INSTALL} -d $(DESTDIR)$(sysconfdir); \
+ conf=$(DESTDIR)$(sysconfdir)/wydawca.rc; \
+ if [ -r $$conf ]; then \
+ echo $$conf | sed 's,.,=,g'; \
+ echo "Warning: The configuration file $$conf already exists"; \
+ echo "Make sure it is up to date!"; \
+ echo $$conf | sed 's,.,=,g'; \
+ else \
+ for file in $(EXTRA_DIST); do \
+ ${INSTALL} -m 600 $(top_srcdir)/etc/$$file \
+ $(DESTDIR)$(sysconfdir)/$$file; \
+ done; \
+ fi
+

Return to:

Send suggestions and report system problems to the System administrator.