aboutsummaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 88ba67f..97adffb 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -24,25 +24,25 @@ clean-local:
AM_MAKEINFOFLAGS = @IMPRIMATUR_MAKEINFOFLAGS@
imprimatur_INPUT=$(info_TEXINFOS) $(wydawca_TEXINFOS)
include ../imprimatur/imprimatur.mk
CHECK_DOCS=$(top_srcdir)/@IMPRIMATUR_MODULE_DIR@/check-docs.sh
-GENDOCS=gendocs.sh
+GENDOCS=$(srcdir)/gendocs.sh
+EXTRA_DIST += gendocs.sh
-TEXI2DVI=texi2dvi -t '@set $(RENDITION)' -E
+TEXI2DVI=texi2dvi -t '@set $(RENDITION)' -I $(top_srcdir)/imprimatur
# Make sure you set TEXINPUTS.
# TEXINPUTS=/usr/share/texmf/pdftex/plain/misc/ is ok for most distributions
.PHONY: manual
manual:
TEXINPUTS=$(srcdir):$(top_srcdir)/build-aux:$(TEXINPUTS) \
MAKEINFO="$(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS)" \
TEXI2DVI="$(TEXI2DVI) -t @finalout" \
- TEXI2HTML="texi2html $(AM_MAKEINFOFLAGS)" \
- $(GENDOCS) --texi2html $(PACKAGE) '$(PACKAGE_NAME) manual'
+ $(GENDOCS) --no-copy-images $(PACKAGE) '$(PACKAGE_NAME) manual'
manual.tar.bz2: manual
tar cfj manual.tar.bz2 manual
man-tar: manual.tar.bz2
@@ -60,13 +60,13 @@ check-options:
check-config:
@$(CHECK_DOCS) 'configuration statements' \
'/wydawca_kw\[\] *= *{/,/^}/s/[ \t]*{ *"\([^,"]*\)".*/\1/pg' \
's/@deffnx\{0,1\} {Config} *\([^@, ]*\).*/\1/p' \
$(top_srcdir)/src/config.c -- \
$(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir) -E - \
- $(info_TEXINFOS)
+ $(info_TEXINFOS)
check-sub-config:
@sed -n '/wydawca_kw\[\] *= *{/,/^}/{p}' ../src/config.c ../src/tcpwrap.c|tr '\n{' ' \n'|sed -n '/grecs_type_section/s/"\([^"]*\)".*grecs_type_section,[^,]*,[^,]*,[^,]*,[^,]*,[^,]*, *\(.*\) *}.*/\1 \2/p' | \
while read ident kw; do \
$(CHECK_DOCS) "$$ident configuration statements" \
"/$$kw"'\[\] *= *{/,/^}/s/[ \t]*{ *"\([^,"]*\)".*/\1/pg' \

Return to:

Send suggestions and report system problems to the System administrator.