aboutsummaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am17
1 files changed, 15 insertions, 2 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 721ea29..e37b083 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -101,14 +101,27 @@ check-unrevised:
check-config:
@check-docs.sh 'configuration statements' \
- '/wydawca_keywords\[\] *= *{/,/^}/s/[ \t]*{ *"\([^,"]*\)".*/\1/pg' \
+ '/wydawca_kw\[\] *= *{/,/^}/s/[ \t]*{ *"\([^,"]*\)".*/\1/pg' \
's/@deffnx\{0,1\} {Config} *\([^@,]*\).*/\1/p' \
$(top_srcdir)/src/config.c -- \
$(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir) -E - \
$(info_TEXINFOS)
+check-sub-config:
+ @sed -n '/wydawca_kw\[\] *= *{/,/^}/{p}' ../src/config.c|tr '\n{' ' \n'|sed -n '/grecs_type_section/s/"\([^"]*\)".*grecs_type_section,[^,]*,[^,]*,[^,]*,[^,]*, *\(.*\) *}.*/\1 \2/p' | \
+ while read ident kw; do \
+ check-docs.sh "$$ident configuration statements" \
+ "/$$kw"'\[\] *= *{/,/^}/s/[ \t]*{ *"\([^,"]*\)".*/\1/pg' \
+ "s/@deffnx\{0,1\} {Config: *$${ident}}"' *\([^@,]*\).*/\1/p' \
+ $(top_srcdir)/src/config.c -- \
+ $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir) -E - \
+ $(info_TEXINFOS); \
+ done
+
-all-check-docs: check-format check-options check-refs check-fixmes check-unrevised check-writeme
+all-check-docs: check-format check-options \
+ check-config check-sub-config \
+ check-refs check-fixmes check-writeme check-unrevised
check-docs:
$(MAKE) -k all-check-docs

Return to:

Send suggestions and report system problems to the System administrator.