aboutsummaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 32f3c9d..2fe7be7 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -102,18 +102,18 @@ check-unrevised:
check-config:
@check-docs.sh 'configuration statements' \
'/wydawca_kw\[\] *= *{/,/^}/s/[ \t]*{ *"\([^,"]*\)".*/\1/pg' \
- 's/@deffnx\{0,1\} {Config} *\([^@,]*\).*/\1/p' \
+ 's/@deffnx\{0,1\} {Config} *\([^@, ]*\).*/\1/p' \
$(top_srcdir)/src/config.c -- \
$(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir) -E - \
$(info_TEXINFOS)
check-sub-config:
- @sed -n '/wydawca_kw\[\] *= *{/,/^}/{p}' ../src/config.c|tr '\n{' ' \n'|sed -n '/grecs_type_section/s/"\([^"]*\)".*grecs_type_section,[^,]*,[^,]*,[^,]*,[^,]*, *\(.*\) *}.*/\1 \2/p' | \
+ @sed -n '/wydawca_kw\[\] *= *{/,/^}/{p}' ../src/config.c ../src/tcpwrap.c|tr '\n{' ' \n'|sed -n '/grecs_type_section/s/"\([^"]*\)".*grecs_type_section,[^,]*,[^,]*,[^,]*,[^,]*, *\(.*\) *}.*/\1 \2/p' | \
while read ident kw; do \
check-docs.sh "$$ident configuration statements" \
"/$$kw"'\[\] *= *{/,/^}/s/[ \t]*{ *"\([^,"]*\)".*/\1/pg' \
- "s/@deffnx\{0,1\} {Config: *$${ident}}"' *\([^@,]*\).*/\1/p' \
- $(top_srcdir)/src/config.c -- \
+ "s/@deffnx\{0,1\} {Config: *$${ident}}"' *\([^@, ]*\).*/\1/p' \
+ $(top_srcdir)/src/config.c $(top_srcdir)/src/tcpwrap.c -- \
$(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir) -E - \
$(info_TEXINFOS); \
done

Return to:

Send suggestions and report system problems to the System administrator.