aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 0 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 7002fb9..344c3b8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -17,46 +17,42 @@
AC_PREREQ(2.63)
AC_INIT([wydawca], 2.1.90, [bug-wydawca@gnu.org.ua])
AC_CONFIG_SRCDIR([src/wydawca.c])
AC_CONFIG_AUX_DIR([build-aux])
AC_CONFIG_HEADER([config.h])
AM_INIT_AUTOMAKE([1.11 gnits tar-ustar dist-bzip2 dist-xz std-options silent-rules])
# Enable silent rules by default:
AM_SILENT_RULES([yes])
# Checks for programs.
AC_PROG_CC
-gl_EARLY
-AC_PROG_LEX
-AC_PROG_YACC
AC_PROG_RANLIB
# Checks for libraries.
# Checks for header files.
AC_HEADER_STDC
AC_HEADER_SYS_WAIT
AC_CHECK_HEADERS([stdlib.h string.h sys/file.h unistd.h])
# Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
AC_TYPE_SIGNAL
AC_TYPE_UID_T
AC_TYPE_PID_T
AC_TYPE_SIZE_T
AC_HEADER_STDBOOL
# Checks for library functions.
-gl_INIT
AC_FUNC_FORK
AC_FUNC_MALLOC
AC_FUNC_MEMCMP
AC_FUNC_STAT
AC_FUNC_VPRINTF
AC_CHECK_FUNCS([fchdir memset strchr strdup strerror strrchr setegid setregid setresgid setresuid seteuid setreuid vsyslog sysconf getdtablesize])
# **********************
# Mailutils
# **********************
AM_GNU_MAILUTILS(2.0, [mailer], [:])
@@ -126,17 +122,16 @@ AH_BOTTOM([
# Initialize the test suite.
AC_CONFIG_TESTDIR(tests)
AC_CONFIG_FILES([tests/Makefile tests/atlocal tests/etc/Makefile])
AM_MISSING_PROG([AUTOM4TE], [autom4te])
AC_PATH_PROG(GPG, gpg, '')
if test -n "$GPG"; then
AC_SUBST(WYDAWCA_GPGFILES, '$(GPGFILES)')
fi
AC_CONFIG_FILES([Makefile
doc/Makefile
- gnu/Makefile
src/Makefile
etc/Makefile])
AC_OUTPUT

Return to:

Send suggestions and report system problems to the System administrator.