aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 19 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 0e1366b..865d206 100644
--- a/configure.ac
+++ b/configure.ac
@@ -110,7 +110,7 @@ AH_BOTTOM(
#endif
])
LDADD=$saved_LDADD
-
+
# **********************
# TCP wrappers
# **********************
@@ -176,10 +176,24 @@ AM_MISSING_PROG([AUTOM4TE], [autom4te])
# Initialize documentation helpers.
IMPRIMATUR_INIT(, [frenchspacing])
-AC_PATH_PROG(GPG, gpg, '')
-if test -n "$GPG"; then
- AC_SUBST(WYDAWCA_GPGFILES, '$(GPGFILES)')
-fi
+# **********************
+# GPG v2 (for the testsuite)
+# **********************
+AC_ARG_VAR([GPG],[Name of the gpg version 2 binary])
+AC_MSG_CHECKING([for the GPG v2 binary])
+uGPG=$GPG
+unset GPG
+for prog in $uGPG gpg2 gpg
+do
+ ver=$($prog --version 2>/dev/null | head -n 1)
+ case $ver in
+ "gpg (GnuPG) 2."*)
+ GPG=$prog
+ break;;
+ esac
+done
+AC_MSG_RESULT([${GPG:-none}${GPG:+, $ver}])
+AM_CONDITIONAL([COND_GPG2],[test -n "$GPG"])
AC_CONFIG_FILES([Makefile
doc/Makefile

Return to:

Send suggestions and report system problems to the System administrator.