aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 29 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index a503cc7..2683b9b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -15,7 +15,8 @@
15# along with wydawca. If not, see <http://www.gnu.org/licenses/>. 15# along with wydawca. If not, see <http://www.gnu.org/licenses/>.
16 16
17AC_PREREQ(2.63) 17AC_PREREQ(2.63)
18AC_INIT([wydawca], 2.1.90, [bug-wydawca@gnu.org.ua]) 18AC_INIT([wydawca], 2.1.90, [bug-wydawca@gnu.org.ua], [wydawca],
19 [http://www.gnu.org.ua/software/wydawca])
19AC_CONFIG_SRCDIR([src/wydawca.c]) 20AC_CONFIG_SRCDIR([src/wydawca.c])
20AC_CONFIG_AUX_DIR([build-aux]) 21AC_CONFIG_AUX_DIR([build-aux])
21AC_CONFIG_HEADER([config.h]) 22AC_CONFIG_HEADER([config.h])
@@ -33,7 +34,7 @@ AC_PROG_RANLIB
33# Checks for header files. 34# Checks for header files.
34AC_HEADER_STDC 35AC_HEADER_STDC
35AC_HEADER_SYS_WAIT 36AC_HEADER_SYS_WAIT
36AC_CHECK_HEADERS([stdlib.h string.h sys/file.h unistd.h]) 37AC_CHECK_HEADERS([stdlib.h string.h sys/file.h unistd.h sys/inotify.h])
37 38
38# Checks for typedefs, structures, and compiler characteristics. 39# Checks for typedefs, structures, and compiler characteristics.
39AC_C_CONST 40AC_C_CONST
@@ -50,7 +51,9 @@ AC_FUNC_MALLOC
50AC_FUNC_MEMCMP 51AC_FUNC_MEMCMP
51AC_FUNC_STAT 52AC_FUNC_STAT
52AC_FUNC_VPRINTF 53AC_FUNC_VPRINTF
53AC_CHECK_FUNCS([fchdir memset strchr strdup strerror strrchr setegid setregid setresgid setresuid seteuid setreuid vsyslog sysconf getdtablesize]) 54AC_CHECK_FUNCS([fchdir memset strchr strdup strerror strrchr setegid setregid\
55 setresgid setresuid seteuid setreuid vsyslog sysconf getdtablesize\
56 inotify_init])
54 57
55# ********************** 58# **********************
56# Mailutils 59# Mailutils
@@ -107,6 +110,29 @@ if test "$status_tcpwrap" = yes; then
107 AC_DEFINE_UNQUOTED([WITH_LIBWRAP],1,[Defined if compiling with libwrap]) 110 AC_DEFINE_UNQUOTED([WITH_LIBWRAP],1,[Defined if compiling with libwrap])
108fi 111fi
109 112
113# **********************
114# TCP wrappers
115# **********************
116AC_ARG_WITH(inotify,
117 AC_HELP_STRING([--with-inotify],
118 [compile with inotify(7) support (Linux-specific)]),
119 [status_inotify=${withval}],
120 [status_inotify=probe])
121if test $status_inotify != no; then
122 if test "$ac_cv_header_sys_inotify_h" = yes &&
123 test "$ac_cv_func_inotify_init" = yes; then
124 status_inotify=yes
125 elif test $status_inotify = probe; then
126 status_inotify=no
127 else
128 AC_MSG_FAILURE([Requested inotify(7) support is not available])
129 fi
130fi
131if test $status_inotify = yes; then
132 AC_DEFINE([WITH_INOTIFY],1,[Set to 1 if inotify(7) is to be used])
133fi
134AM_CONDITIONAL([COND_INOTIFY],[test $status_inotify = yes])
135
110# Grecs subsystem 136# Grecs subsystem
111GRECS_SETUP([grecs],[git2chg getopt tests]) 137GRECS_SETUP([grecs],[git2chg getopt tests])
112 138

Return to:

Send suggestions and report system problems to the System administrator.