aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 29 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index a503cc7..2683b9b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -15,7 +15,8 @@
# along with wydawca. If not, see <http://www.gnu.org/licenses/>.
AC_PREREQ(2.63)
-AC_INIT([wydawca], 2.1.90, [bug-wydawca@gnu.org.ua])
+AC_INIT([wydawca], 2.1.90, [bug-wydawca@gnu.org.ua], [wydawca],
+ [http://www.gnu.org.ua/software/wydawca])
AC_CONFIG_SRCDIR([src/wydawca.c])
AC_CONFIG_AUX_DIR([build-aux])
AC_CONFIG_HEADER([config.h])
@@ -33,7 +34,7 @@ AC_PROG_RANLIB
# Checks for header files.
AC_HEADER_STDC
AC_HEADER_SYS_WAIT
-AC_CHECK_HEADERS([stdlib.h string.h sys/file.h unistd.h])
+AC_CHECK_HEADERS([stdlib.h string.h sys/file.h unistd.h sys/inotify.h])
# Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
@@ -50,7 +51,9 @@ AC_FUNC_MALLOC
AC_FUNC_MEMCMP
AC_FUNC_STAT
AC_FUNC_VPRINTF
-AC_CHECK_FUNCS([fchdir memset strchr strdup strerror strrchr setegid setregid setresgid setresuid seteuid setreuid vsyslog sysconf getdtablesize])
+AC_CHECK_FUNCS([fchdir memset strchr strdup strerror strrchr setegid setregid\
+ setresgid setresuid seteuid setreuid vsyslog sysconf getdtablesize\
+ inotify_init])
# **********************
# Mailutils
@@ -107,6 +110,29 @@ if test "$status_tcpwrap" = yes; then
AC_DEFINE_UNQUOTED([WITH_LIBWRAP],1,[Defined if compiling with libwrap])
fi
+# **********************
+# TCP wrappers
+# **********************
+AC_ARG_WITH(inotify,
+ AC_HELP_STRING([--with-inotify],
+ [compile with inotify(7) support (Linux-specific)]),
+ [status_inotify=${withval}],
+ [status_inotify=probe])
+if test $status_inotify != no; then
+ if test "$ac_cv_header_sys_inotify_h" = yes &&
+ test "$ac_cv_func_inotify_init" = yes; then
+ status_inotify=yes
+ elif test $status_inotify = probe; then
+ status_inotify=no
+ else
+ AC_MSG_FAILURE([Requested inotify(7) support is not available])
+ fi
+fi
+if test $status_inotify = yes; then
+ AC_DEFINE([WITH_INOTIFY],1,[Set to 1 if inotify(7) is to be used])
+fi
+AM_CONDITIONAL([COND_INOTIFY],[test $status_inotify = yes])
+
# Grecs subsystem
GRECS_SETUP([grecs],[git2chg getopt tests])

Return to:

Send suggestions and report system problems to the System administrator.