aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac46
1 files changed, 4 insertions, 42 deletions
diff --git a/configure.ac b/configure.ac
index 604ccc4..48e1252 100644
--- a/configure.ac
+++ b/configure.ac
@@ -106,48 +106,9 @@ fi
106if test "$status_tcpwrap" = yes; then 106if test "$status_tcpwrap" = yes; then
107 AC_DEFINE_UNQUOTED([WITH_LIBWRAP],1,[Defined if compiling with libwrap]) 107 AC_DEFINE_UNQUOTED([WITH_LIBWRAP],1,[Defined if compiling with libwrap])
108fi 108fi
109
110# **********************
111# Preprocessor
112# **********************
113AC_ARG_WITH([preprocessor],
114 AC_HELP_STRING([--without-preprocessor],
115 [do not use external preprocessor]),
116 [
117case "${withval}" in
118yes) use_ext_pp=yes ;;
119no) use_ext_pp=no ;;
120*) AC_MSG_ERROR(bad value ${withval} for --with-preprocessor) ;;
121esac],[use_ext_pp=yes])
122
123if test $use_ext_pp != no; then
124 # Check for default preprocessor
125 AC_ARG_VAR([DEFAULT_PREPROCESSOR],
126 [Set default preprocessor name])
127 if test -z "$DEFAULT_PREPROCESSOR" ; then
128 DEFAULT_PREPROCESSOR="m4 -s"
129 fi
130
131 save_PATH=$PATH
132 PREPROC_OPTIONS=`echo $DEFAULT_PREPROCESSOR | sed -n 's/[[^ ]][[^ ]]* //p'`
133 case "$DEFAULT_PREPROCESSOR" in
134 /*) PATH=`expr $DEFAULT_PREPROCESSOR : '\(.*\)/.*'`:$PATH
135 DEFAULT_PREPROCESSOR=`expr $DEFAULT_PREPROCESSOR : '.*/\(.*\)'`;;
136 esac
137 AC_PATH_PROG(PPBIN, $DEFAULT_PREPROCESSOR)
138 DEFAULT_PREPROCESSOR=$PPBIN
139 if test -n "$DEFAULT_PREPROCESSOR"; then
140 DEFAULT_PREPROCESSOR="$DEFAULT_PREPROCESSOR $PREPROC_OPTIONS"
141 case $PPBIN in
142 *m4) AC_SUBST(PP_SETUP_FILE,'pp-setup');; # Install default pp-setup
143 esac
144 fi
145 PATH=$save_PATH
146 DEFAULT_PREPROCESSOR="\\\"$DEFAULT_PREPROCESSOR\\\""
147else
148 DEFAULT_PREPROCESSOR=NULL
149fi
150 109
110# Grecs subsystem
111GRECS_SETUP
151 112
152AH_BOTTOM([ 113AH_BOTTOM([
153#if __GNUC__ < 2 || (__GNUC__ == 2 && __GNUC_MINOR__ < 7) 114#if __GNUC__ < 2 || (__GNUC__ == 2 && __GNUC_MINOR__ < 7)
@@ -172,7 +133,8 @@ fi
172AC_CONFIG_FILES([Makefile 133AC_CONFIG_FILES([Makefile
173 doc/Makefile 134 doc/Makefile
174 gnu/Makefile 135 gnu/Makefile
175 gconf/Makefile 136 grecs/Makefile
137 grecs/src/Makefile
176 src/Makefile 138 src/Makefile
177 etc/Makefile]) 139 etc/Makefile])
178 140

Return to:

Send suggestions and report system problems to the System administrator.