aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4f6eaa0..737e2dc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -88,6 +88,26 @@ WD_CHECK_LIB([gpgme],[main],[],
[/usr/pkg/lib /opt/lib /sw/lib])
# **********************
+# TCP wrappers
+# **********************
+AC_ARG_WITH(tcp-wrappers,
+ AC_HELP_STRING([--with-tcp-wrappers],
+ [compile with TCP wrappers support (default)]),
+ [status_tcpwrap=${withval}],
+ [status_tcpwrap=yes])
+
+if test "$status_tcpwrap" = yes; then
+ AC_CHECK_LIB(nsl, main)
+ AC_CHECK_LIB(wrap, main,, [status_tcpwrap=no])
+ if test "$status_tcpwrap" = yes; then
+ AC_CHECK_HEADERS(tcpd.h,,[status_tcpwrap=no])
+ fi
+fi
+if test "$status_tcpwrap" = yes; then
+ AC_DEFINE_UNQUOTED([WITH_LIBWRAP],1,[Defined if compiling with libwrap])
+fi
+
+# **********************
# Preprocessor
# **********************
AC_ARG_WITH([preprocessor],

Return to:

Send suggestions and report system problems to the System administrator.