aboutsummaryrefslogtreecommitdiff
path: root/tests/etc/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2009-02-16 16:17:03 +0200
committerSergey Poznyakoff <gray@gnu.org.ua>2009-02-16 16:23:53 +0200
commit6cfe6f8fe1b7506e772403fecc9d7298fc52dc74 (patch)
tree64e579d8895bfecfadceb9914f9f795d75e4ccbb /tests/etc/Makefile.am
parent98ca4bb1bc96cc95bdd141cb653b17029957de38 (diff)
downloadwydawca-6cfe6f8fe1b7506e772403fecc9d7298fc52dc74.tar.gz
wydawca-6cfe6f8fe1b7506e772403fecc9d7298fc52dc74.tar.bz2
Improve keyword (meta) expansion, add testsuite framework
* src/meta.c: New file. * src/Makefile.am (wydawca_SOURCES): Add meta.c. * Makefile.am (SUBDIRS): Add tests. * configure.ac: Initialize testsuite. * src/cmdline.opt: Add preprocessor-related options: --[no-]preprocessor, -E * src/mail.c, src/triplet.c, src/verify.c, src/wydawca.c, src/wydawca.h: Use new expansion functions. * src/update-2.0.awk: Replace % markup with $. * etc/wydawca.rc: Switch to new meta-variable syntax. * gnulib.modules: Add c-ctype. * doc/Makefile.am (check-options): Rewrite. * doc/wydawca.texi: Mark unrevised/obsolete material. * tests/: New directory
Diffstat (limited to 'tests/etc/Makefile.am')
-rw-r--r--tests/etc/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/tests/etc/Makefile.am b/tests/etc/Makefile.am
new file mode 100644
index 0000000..af7b28e
--- /dev/null
+++ b/tests/etc/Makefile.am
@@ -0,0 +1,27 @@
+# This file is part of Wydawca
+# Copyright (C) 2009 Sergey Poznyakoff
+#
+# Wydawca is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# Wydawca is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with Wydawca. If not, see <http://www.gnu.org/licenses/>.
+
+GPGFILES = secring.gpg pubring.gpg
+noinst_DATA = @WYDAWCA_GPGFILES@
+
+EXTRA_DIST = pubring.asc secring.asc
+
+GPG_FLAGS = --quiet --no-permission-warning --homedir .
+pubring.gpg secring.gpg: $(srcdir)/pubring.asc $(srcdir)/secring.asc
+ $(GPG) $(GPG_FLAGS) --import < $(srcdir)/pubring.asc
+ $(GPG) $(GPG_FLAGS) --allow-secret-key-import --import < $(srcdir)/secring.asc
+
+DISTCLEANFILES = *.gpg *.gpg~

Return to:

Send suggestions and report system problems to the System administrator.