aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org>2017-11-11 11:10:49 +0200
committerSergey Poznyakoff <gray@gnu.org>2017-11-11 11:10:49 +0200
commit499992bf3bbf7e7d3e1203563f856f6db229d73c (patch)
treee34d7f1c16bef5ce978fe40a35f41abea5a3f49f /tests/Makefile.am
parentba1c15e2290246d272037404c46f44abd9d98c0e (diff)
downloadwydawca-499992bf3bbf7e7d3e1203563f856f6db229d73c.tar.gz
wydawca-499992bf3bbf7e7d3e1203563f856f6db229d73c.tar.bz2
Fix build with mailutils 3.4
* Makefile.am (ACLOCAL_AMFLAGS): Add am. * NEWS: Update. * am/mailutils.m4: New file. A fixed version of upstream mailutils.m4 * configure.ac: Require mailutils 3.3. Raise patchlevel. * tests/nullmail.c: New file. * tests/.gitignore: Add nullmail * tests/Makefile.am: Build nullmail * tests/etc/nullmail: Remove * tests/etc/Makefile.am: Remove nullmail script. * tests/atlocal.in (WY_TESTDIR): New variable. * tests/check-notify.at: Use new nullmail tool. Update expected output. * tests/mailstats.at: Likewise. * tests/notify-upl.at: Likewise. * tests/etc/mailstats.rcin: Fix mailer command line. * tests/etc/notify.rcin: Likewise.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 3f7a491..ebd86ff 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -80,7 +80,7 @@ check-local: atconfig atlocal $(TESTSUITE)
80#installcheck-local: 80#installcheck-local:
81# $(SHELL) $(TESTSUITE) AUTOTEST_PATH=$(exec_prefix)/bin 81# $(SHELL) $(TESTSUITE) AUTOTEST_PATH=$(exec_prefix)/bin
82 82
83check_PROGRAMS = wstest wsbatch pushck bkupname 83check_PROGRAMS = wstest wsbatch pushck bkupname
84AM_CPPFLAGS = \ 84AM_CPPFLAGS = \
85 -I$(top_srcdir)/grecs/src\ 85 -I$(top_srcdir)/grecs/src\
86 -I$(top_srcdir)/include\ 86 -I$(top_srcdir)/include\
@@ -90,3 +90,7 @@ LDADD=@GRECS_LDADD@
90pushck_LDADD=../src/pushd.o 90pushck_LDADD=../src/pushd.o
91bkupname_LDADD=../src/backup.o @GRECS_LDADD@ 91bkupname_LDADD=../src/backup.o @GRECS_LDADD@
92 92
93if COND_MAILUTILS
94 check_PROGRAMS += nullmail
95 nullmail_LDADD = @MAILUTILS_LIBS@
96endif

Return to:

Send suggestions and report system problems to the System administrator.