aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2009-02-16 13:09:28 +0200
committerSergey Poznyakoff <gray@gnu.org.ua>2009-02-16 13:09:28 +0200
commitb0f10ec7274144b4e048953b11f2a4d98e055810 (patch)
tree4bcc06122d183582d0b53fe2b8ba4c87b289b96f /src/Makefile.am
parent169a680208f2de8f92b4a2a4977953d4452e981f (diff)
downloadwydawca-b0f10ec7274144b4e048953b11f2a4d98e055810.tar.gz
wydawca-b0f10ec7274144b4e048953b11f2a4d98e055810.tar.bz2
Improve argument parsing
* src/cmdline.opt, src/getopt.m4: New files. * src/wydawca.c: Switch to new way of command line parsing. * src/wydawca.h (gettext): Define. * bootstrap.conf: Add formatting flags for gconf_warning and gconf_error * gconf-preproc.c (pp_list_find): Minor change. * gconf/gconf.h (gconf_warning,gconf_error): Mark as printflike. * src/.gitignore: Add cmdline.h * src/Makefile.am (wydawca_SOURCES): Add cmdline.h. (.opt.h): New rule. * src/config.c (cb_archive): Archive is now a block statement (unless type "none" is declared). (all functions): Tighten input checking * src/update-2.0.awk: Reflect the above change. * src/directive.c (process_directives): Minor change. * src/diskio.c (symlink_file): Minor change.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index a6611af..10a6b60 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -16,6 +16,7 @@
sbin_PROGRAMS=wydawca
wydawca_SOURCES=\
+ cmdline.h\
config.c\
directive.c\
diskio.c\
@@ -33,7 +34,13 @@ wydawca_SOURCES=\
mail.h\
mail.c
-EXTRA_DIST=pp-setup
+BUILT_SOURCES=cmdline.h
+EXTRA_DIST=cmdline.opt getopt.m4 pp-setup
+
+SUFFIXES=.opt .c .h
+
+.opt.h:
+ m4 -s $(srcdir)/getopt.m4 $< | sed '1d' > $@
incdir=$(pkgdatadir)/$(VERSION)/include
inc_DATA = $(PP_SETUP_FILE)

Return to:

Send suggestions and report system problems to the System administrator.