aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org>2020-04-16 19:54:23 +0300
committerSergey Poznyakoff <gray@gnu.org>2020-04-16 20:03:29 +0300
commita6cc8f5fcbcbf4c707149940de2ee9a33220c34d (patch)
tree3b0da6ae669a58779c9f40503191e6808a60e1b9 /src/Makefile.am
parent2cc5b63b5f90d2dd9b05f50ac28e379d417f1a8c (diff)
downloadwydawca-a6cc8f5fcbcbf4c707149940de2ee9a33220c34d.tar.gz
wydawca-a6cc8f5fcbcbf4c707149940de2ee9a33220c34d.tar.bz2
Rewrite as a multi-threaded program.
* NEWS: Update. * configure.ac: Version 3.1.95 * src/Makefile.am (wydawca_SOURCES): Remove job.c (LDADD): Link with libpthread. * src/job.c: Remove. * src/config.c: Remove the wakeup-interval statement. * src/net.c (wydawca_listener): Rewrite as a thread function wy_thr_listen. * src/timer.c (timer_get): Use thread-specific storage. (timer_get_count): Remove. * src/triplet.c: Rewrite using multi-thread model. * src/wydawca.c: Likewise. * src/wydawca.h: Update. * tests/check-fail.at: Update expected output. * tests/check-notify.at: Likewise. * tests/inotify-ok.at: Likewise. * tests/inotify-rmsymlink.at: Likewise. * tests/inotify-symlink.at: Likewise. * tests/inotify-unatt00.at: Likewise. * tests/inotify-unatt01.at: Likewise. * tests/upl12f.at: Likewise. * tests/upload-dry.at: Likewise. `
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 6e67c9c..9d9d4d9 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -33,7 +33,6 @@ wydawca_SOURCES=\
event.c\
gpg.c\
interval.c\
- job.c\
lock.c\
module.c\
net.c\
@@ -61,7 +60,7 @@ SUFFIXES=.opt .c .h
.opt.h:
$(AM_V_GEN)m4 -s $(top_srcdir)/@GRECS_SUBDIR@/build-aux/getopt.m4 $< > $@
-LDADD=@GRECS_LDADD@ @SQLLIB@ @GPGMELIB@ @LIBLTDL@
+LDADD=@GRECS_LDADD@ @SQLLIB@ @GPGMELIB@ @LIBLTDL@ -lpthread
AM_CPPFLAGS= \
-I$(top_srcdir)/include\
@GRECS_INCLUDES@ @MAILUTILS_INCLUDES@\

Return to:

Send suggestions and report system problems to the System administrator.