aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org>2020-04-27 13:44:31 +0300
committerSergey Poznyakoff <gray@gnu.org>2020-04-27 13:44:31 +0300
commit9dff021e31a300dcd5eda941d9e4992a6a8e465a (patch)
tree9ba56aa2ccbd7c24b1d1e8535c8e3eeef25f27cf /src/Makefile.am
parente19cf8e1303700b5b2e4f3e525285f63a3c7b51f (diff)
downloadwydawca-9dff021e31a300dcd5eda941d9e4992a6a8e465a.tar.gz
wydawca-9dff021e31a300dcd5eda941d9e4992a6a8e465a.tar.bz2
Use BSD queue macros to implement queues and linked lists.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am13
1 files changed, 6 insertions, 7 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5af4c2c..5b70f5e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -16,10 +16,6 @@
sbin_PROGRAMS=wydawca
-if COND_INOTIFY
- WATCHER_C=watcher.c
-endif
-
wydawca_SOURCES=\
backup.c\
builtin.c\
@@ -30,13 +26,12 @@ wydawca_SOURCES=\
directive.c\
diskio.c\
exec.c\
- event.c\
gpg.c\
interval.c\
module.c\
net.c\
pidfile.c\
- process.c\
+ spool.c\
sql.c\
sql.h\
tcpwrap.c\
@@ -49,7 +44,11 @@ wydawca_SOURCES=\
null.c\
timer.c\
thread_name.c\
- $(WATCHER_C)
+ queue.h
+
+if COND_INOTIFY
+ wydawca_SOURCES += watcher.c
+endif
BUILT_SOURCES=cmdline.h
EXTRA_DIST=cmdline.opt

Return to:

Send suggestions and report system problems to the System administrator.