aboutsummaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2007-09-02 08:23:21 +0000
committerSergey Poznyakoff <gray@gnu.org.ua>2007-09-02 08:23:21 +0000
commitec3f48e906c8b80e6513ac887a2f92c59ee3f8e5 (patch)
treed89db8c8164ef0c09e76cc6a44d9759cc61f84ad /doc/Makefile.am
parent667cacb84f511af316f28bd41fcaa8ed02221015 (diff)
downloadwydawca-ec3f48e906c8b80e6513ac887a2f92c59ee3f8e5.tar.gz
wydawca-ec3f48e906c8b80e6513ac887a2f92c59ee3f8e5.tar.bz2
Set up documentation framework
git-svn-id: file:///svnroot/wydawca/trunk@307 6bb4bd81-ecc2-4fd4-a2d4-9571d19c0d33
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am55
1 files changed, 54 insertions, 1 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index a06751b..fb4d036 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -15,7 +15,7 @@
# with this program. If not, see <http://www.gnu.org/licenses/>.
info_TEXINFOS=wydawca.texi
-wydawca_TEXINFOS=fdl.texi rendition.texi
+wydawca_TEXINFOS=fdl.texi rendition.texi macros.texi
EXTRA_DIST = gendocs_template
@@ -40,3 +40,56 @@ manual:
TEXI2DVI="$(TEXI2DVI) -t @finalout" \
$(GENDOCS) $(PACKAGE) '$(PACKAGE_NAME) manual'
+# Checking
+check-format:
+ @if test -n "`cat $(info_TEXINFOS) $(wydawca_TEXINFOS) | tr -d -c '\t'`"; then \
+ echo "Sources contain tabs; run make untabify"; \
+ false; \
+ fi
+
+check-options:
+ @check-docs.sh options \
+ '/option options\[\] = /,/^}/s/[ \t]*{ *"\([^,"]*\)".*/\1/pg' \
+ 's/@opindex *\([^@,]*\), --.*/\1/p' \
+ $(top_srcdir)/src/wydawca.c -- \
+ $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir) -E - \
+ $(info_TEXINFOS)
+
+check-refs:
+ @sed -e = $(info_TEXINFOS) $(wydawca_TEXINFOS) | \
+ sed -n 'N;/@FIXME-.*ref/{s/\(^[0-9][0-9]*\).*@FIXME-.*ref{\([^}]*\)}.*/$(info_TEXINFOS):\1: \2/gp}' > $@-t; \
+ if [ -s $@-t ]; then echo "Unresolved cross-references:"; cat $@-t;\
+ fi
+ rm -f $@-t
+
+check-fixmes:
+ @sed -e = $(info_TEXINFOS) | \
+ sed -n 'N;/@FIXME{/{s/\(^[0-9][0-9]*\).*@FIXME{\([^}]*\).*/$(info_TEXINFOS):\1: \2/gp}' > $@-t; \
+ if [ -s $@-t ]; then echo "Unresolved FIXMEs:"; cat $@-t;\
+ fi
+ rm -f $@-t
+
+check-unrevised:
+ @grep -Hn @UNREVISED $(info_TEXINFOS) > $@-t; \
+ if [ -s $@-t ]; then \
+ echo "Unrevised nodes:"; \
+ cat $@-t; \
+ rm $@-t; \
+ false;\
+ else \
+ rm $@-t; \
+ fi
+
+all-check-docs: check-format check-options check-refs check-fixmes check-unrevised
+
+check-docs:
+ $(MAKE) -k all-check-docs
+
+master-menu:
+ emacs -batch -l mastermenu.el -f make-master-menu $(info_TEXINFOS)
+
+untabify:
+ emacs -batch -l untabify.el $(info_TEXINFOS) $(wydawca_TEXINFOS)
+
+final: untabify master-menu
+

Return to:

Send suggestions and report system problems to the System administrator.