aboutsummaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2007-09-01 12:46:05 +0000
committerSergey Poznyakoff <gray@gnu.org.ua>2007-09-01 12:46:05 +0000
commitd6fe9fcb4c3ca8a6d825590bf513bae6d0a81e1f (patch)
treef8d0b7334b1cd7b2ea765abd1cdccd965ac4454a /doc/Makefile.am
parent8c3e4b2576fae10c60aaef6c224324a3f61c903b (diff)
downloadwydawca-d6fe9fcb4c3ca8a6d825590bf513bae6d0a81e1f.tar.gz
wydawca-d6fe9fcb4c3ca8a6d825590bf513bae6d0a81e1f.tar.bz2
Initial move from GSC
git-svn-id: file:///svnroot/wydawca/trunk@305 6bb4bd81-ecc2-4fd4-a2d4-9571d19c0d33
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
new file mode 100644
index 0000000..a06751b
--- /dev/null
+++ b/doc/Makefile.am
@@ -0,0 +1,42 @@
+# This file is part of Wydawca
+# Copyright (C) 2007 Sergey Poznyakoff
+#
+# This program is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by the Free
+# Software Foundation; either version 3 of the License, or (at your option)
+# any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program. If not, see <http://www.gnu.org/licenses/>.
+
+info_TEXINFOS=wydawca.texi
+wydawca_TEXINFOS=fdl.texi rendition.texi
+
+EXTRA_DIST = gendocs_template
+
+clean-local:
+ rm -rf manual
+
+# The rendering level is one of PUBLISH, DISTRIB or PROOF.
+# Just call `make RENDITION=PROOF [target]' if you want PROOF rendition.
+RENDITION = DISTRIB
+
+MAKEINFOFLAGS=-D$(RENDITION)
+
+GENDOCS=gendocs.sh
+
+TEXI2DVI=texi2dvi -t '@set $(RENDITION)' -E
+
+# Make sure you set TEXINPUTS.
+# TEXINPUTS=/usr/share/texmf/pdftex/plain/misc/ is ok for most distributions
+manual:
+ TEXINPUTS=$(srcdir):$(top_srcdir)/build-aux:$(TEXINPUTS) \
+ MAKEINFO="$(MAKEINFO) $(MAKEINFOFLAGS)" \
+ TEXI2DVI="$(TEXI2DVI) -t @finalout" \
+ $(GENDOCS) $(PACKAGE) '$(PACKAGE_NAME) manual'
+

Return to:

Send suggestions and report system problems to the System administrator.